7-19 PAT Judge(25 分)(结构体排序)

7-19 PAT Judge(25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (104), the total number of users, K (5), the total number of problems, and M (105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either 1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
code:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int n,k,m;//n用户数量,k题目个数,m提交信息个数
int fullmark[6];//每个题目的满分分数

struct user{
    int id;//用户id
    int sflag;//标记是否提交并且通过了编译,是否输出
    int total_score;//总分
    int fullnumber;//满分个数
    int p[6];//每个题的分数
    int pflag[6];//标记每个题目,是输出-还是数字
}stu[10005];

void init(){
    int i,j;
    for(i = 1; i <= n; i++){
        stu[i].id = i;
        stu[i].sflag = 0;
        stu[i].fullnumber = 0;
        stu[i].total_score = 0;
        for(j = 1; j <= k; j++){
            stu[i].p[j] = 0;
            stu[i].pflag[j] = 0;
        }
    }
}

int cmp(const void *a,const void *b){
    struct user* c = (struct user*)a;
    struct user* d = (struct user*)b;
    if(c->total_score == d->total_score){
        if(c->fullnumber == d->fullnumber){
            return c->id > d->id;
        }
        return c->fullnumber < d->fullnumber;
    }
    return c->total_score < d->total_score;
}

int main(){
    int i,j;
    scanf("%d%d%d",&n,&k,&m);
    init();
    for(i = 1; i <= k; i++){
        scanf("%d",&fullmark[i]);
    }//输入每个题的总分
    for(i = 1; i <= m; i++){
        int id,pid,score;
        scanf("%d%d%d",&id,&pid,&score);
        if(score > -1){
            stu[id].sflag = 1;//首先看分数,如果分数大于-1,说明这个用户已经编译通过了一次,那么输出rank时要输出他
            if(score > stu[id].p[pid]){//如果新提交的分数大于原来分数,更新这道题的分数
                stu[id].p[pid] = score;
            }
        }
        stu[id].pflag[pid] = 1;//这道题提交过了应该输出分数,不是'-'
    }
    for(i = 1; i <= n; i++){//算总分和满分数
        if(!stu[i].sflag){
            stu[i].total_score = -2;
            continue;
        }
        for(j = 1; j <= k; j++){
            stu[i].total_score += stu[i].p[j];//算总分每个加起来即可
            if(stu[i].p[j] == fullmark[j]){//如果有满分的,满分数加一
                stu[i].fullnumber++;
            }
        }
    }
    //排序
    qsort(stu+1,n,sizeof(stu[1]),cmp);
    //输出
    int ranks = 1;
    int num = 0;
    for(i = 1; i <= n; i++){
        num++;
        if(!stu[i].sflag)break;
        if(i == 1){
            printf("%d",ranks);
        }
        else{
            if(stu[i].total_score == stu[i-1].total_score){
                printf("%d",ranks);
            }
            else{
                ranks = num;
                printf("%d",ranks);
            }
        }//输出rank
        printf(" %05d %d",stu[i].id,stu[i].total_score);
        for(j = 1; j <= k; j++){
            if(!stu[i].pflag[j]){
                printf(" -");
            }
            else{
                printf(" %d",stu[i].p[j]);
            }
        }//输出分数
        puts("");
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值