1075 PAT Judge (25 分)

今天这道题真的虐哭我了,思路不难,但是,真的是细节,各种各种细节需要注意。终于所有测试用例都通过了,可是这个时候,只能吃泡面了。So sad…..

Ok,切换频道:

1075 PAT Judge (25 分)
The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​的4次方), the total number of users, K (≤5), the total number of problems, and M (≤10
的5次方), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] … s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

注意点:
1、最重要最重要的一点,一定一定要仔细看题,每一个细节,每一句话,都要认真理解。
2、按照总分排序高低排序。
3、总分相同,那么按照答对题目个数(完全正确,拿满分)进行排序。
4、满足2、3条件,那么就需要按照学号进行排序。
5、最后一个输出,一道题都没有提交或者提交但没有一道题通过编译的同学不输出。(一定要注意,提交没有通过编译和提交得零分完全是两个概念,所以在这里输出的时候一定要注意,后者是需要输出的)
6、最后一个注意点是我自己的错,没有注意到第一个数N是user个数,那么下面提交的学生id是1-N。注意到了这一点,不至于把题想得很复杂。
7、输出的时候,提交没有通过编译的题目输出0,没有提交的题目输出“-”
8、做这个题还有一个感受,一门语言,需要好好理解,深入理解,会帮助我们解题。

思路:上面的注意点都想到了的话,那么这道题并不难。First,在输入各个提交情况的时候,简单处理一下,then,计算每个user提交正确的题目数,next,调用一个sort函数进行进行排序,last
,按照格式输出。over…

贴代码啦:

#include <iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define MaxP 6
#define MaxUser 10001
int N,K,M;//学生个数,考题个数,提交数
int Full_Score[MaxP];
/*定义一个学生节点*/
typedef struct Node{
     int id;//学生id
     int flag=0; //判断该生成绩是否输出的标记
     int total_score=0;   //学生的总分
     int score[MaxP]={-1,-1,-1,-1,-1,-1}; //每道题目的得分
     int total_number=0;   //答对正确的题目个数
}Student;
Student studentList[MaxUser];   //定于一个结构体数组存放学生信息
/*输入函数*/
void Input(Student List[]){
   int i,j;
   int tmpid,tmp_problemid,tmpscore;
   //接收每道题的满分
   for(i=1;i<=K;i++){
    cin>>Full_Score[i];
   }
   //处理每一条记录
   for(i=0;i<M;i++){
    cin>>tmpid>>tmp_problemid>>tmpscore;
    List[tmpid].id=tmpid;
    //第一次提交之后,相应的题目分数值先变为0,便于之后计算
    if(List[tmpid].score[tmp_problemid]==-1){
        List[tmpid].score[tmp_problemid]=0;
    }
    //如果对应题目分数>=0.则说明是通过编译是通过的
    if(List[tmpid].score[tmp_problemid]<=tmpscore){
        //设置该学生输出标记为1
        List[tmpid].flag=1;
        //计算总分
        List[tmpid].total_score+=(tmpscore-List[tmpid].score[tmp_problemid]);
        //如果某题目提交多次,则以最高成绩进行记录
        List[tmpid].score[tmp_problemid]=tmpscore;
    }
   }
}
/*计算每个学生完全答对的题目个数*/
void Calculate(Student studentList[]){
    int i,j;
    for(i=1;i<=N;i++){
        if(studentList[i].total_score!=0){
           for(j=1;j<=K;j++){
            if(studentList[i].score[j]==Full_Score[j]){
                studentList[i].total_number++;
            }
           }
        }
    }
}
/*排序函数的依据*/
bool cmp(Student a,Student b){
  if(a.total_score>b.total_score||//按照分数高低排序
     (a.total_score==b.total_score&&a.total_number>b.total_number)||  //分数相同按照完全答对题目个数答对排序
     (a.total_score==b.total_score&&a.total_number==b.total_number&&a.id<b.id)){  //前两者都相同的话,就按照id进行排序
     return true;
     }
  return false;
}
//输出函数
void output(Student studentList[])
{
    int i,j;
    int number=1;
    for(i=1; i<=N; i++)
    {
        //输出标记位1
        if(studentList[i].flag>0){
            cout<<number<<' ';
            if(studentList[i+1].total_score!=studentList[i].total_score){
                number=i+1;
            }
            printf("%05d %d",studentList[i].id,studentList[i].total_score);
            for(j=1;j<=K;j++){
                if(studentList[i].score[j]==-1){
                    printf(" -");
                }
                else{
                    printf(" %d",studentList[i].score[j]);
                }
            }

            printf("\n");
        }

    }
}
int main()
{
    cin>>N>>K>>M;
    Input(studentList);
    Calculate(studentList);
    sort(studentList+1,studentList+N+1,cmp);
    output(studentList);
    return 0;
}

亲自尝试
这里写图片描述

  • 8
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值