1056. Mice and Rice (25)

1056. Mice and Rice (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

有n个老鼠,第一行给出n个老鼠的重量,第二行给出他们的顺序。
1.每一轮分成若干组,每组m个老鼠,不能整除的多余的作为最后一组。
2.每组重量最大的进入下一轮。
让你给出每只老鼠最后的排名。
很简单,用两个数组模拟一下即可
order1存储进入当前一轮老鼠的索引顺序
order2存储进入下一轮老鼠的索引顺序

如果当前有groups个组,那么会有groups个老鼠进入下一轮,则没有进入下一轮的排名都为groups+1
如果只有一个组,那么最大的那个排名即为1。

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1000+5;
struct Mice{
    int weight;
    int ranks;
}mice[maxn];
int order1[maxn];
int cnt1 = 0;
int order2[maxn];
int cnt2 = 0;
int main(){
    int n,m;
    cin >> n >> m;
    for(int i = 0; i < n; i++){
       cin >> mice[i].weight;
    }
    for(int i = 0; i < n; i++){
        cin >> order1[i];
    }
    cnt1 = n;//第一次所有参与比赛的是所有老鼠
    int groups;
    while(1){
        cnt2 = 0;
        int maxw,maxid;
        groups = cnt1 / m;
        if(cnt1 % m != 0)
            groups++;//分小组,最后余下不够m个的为一组
        for(int i = 0; i < cnt1; i += m){//每次一个小组一个小组的查看
            maxw = 0;
            int v;
            for(int j = i; j < i+m && j < cnt1; j++){//小组内每个成员在根据所给的比较顺序比较
                v = order1[j];
                if(mice[v].weight > maxw){
                    maxw = mice[v].weight;
                    maxid = v;
                }//找出这一组内最大的
            }
            for(int j = i; j < i+m && j < cnt1; j++){
                v = order1[j];//其他的非最大的名次为groups+1名
                if(v != maxid){
                    mice[v].ranks = groups+1;//每个组里的最大老鼠为前groups名,剩下的当然就是groups+1名了
                }
            }
            order2[cnt2++] = maxid;//将这个最大的放入order2数组储存下次晋级选手比赛顺序
        }
        if(cnt1 <= m){//如果这个小组是唯一的小组则里面最大的是第一名
            mice[maxid].ranks = 1;
            break;
        }
        for(int i = 0;  i < cnt2; i++){
            order1[i] = order2[i];//赋值得到新的比赛顺序,进项下一轮循环
        }
        cnt1 = cnt2;
    }
    printf("%d",mice[0].ranks);
    for(int i = 1; i < n; i++){
        printf(" %d",mice[i].ranks);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值