Permutation Counting HDU - (dp,递推)

Permutation Counting

HDU - 3664

Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.

Input There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N).
Output Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007. Sample Input
3 0
3 1
Sample Output
1
4


        
  
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
        
 

题意:对于任一种N的排列A,定义它的E值为序列中满足A[i]>i的数的个数。给定N和K(K<=N<=1000),问N的排列中E值为K的个数。

解法:简单DP。dp[i][j]表示i个数的排列中E值为j的个数。假设现在已有一个E值为j的i的排列,对于新加入的一个数i+1,将其加入排列的方法有三:1)把它放最后,加入后E值不变    2)把它和一个满足A[k]>k的数交换,交换后E值不变       3)把它和一个不满足A[k]>k的数交换,交换后E值+1      根据这三种方法得到转移方程dp[i][j] = dp[i - 1][j] + dp[i - 1][j] * j + dp[i - 1][j - 1] * (i - j);

 下面具体解释一下三个式子:

第一个 dp[i-1][j]就代表这i-1个数字时已经达到了j值,而且把新加的元素放在了最后一个,所以dp[i-1][j]有几种新的数列就几种

第二个 dp[i-1][j]代表i-1个数字时就达到了j值,这是新加的元素不是放在最后而是去和那j个满足ak>k的元素交换,值不变,共有j种交换方式所以 dp[i-1][j] * j

第三个 dp[i-1][j-1] 代表i-1个数字时的值是j-1,说明还差一个,也就是在i-1个元素中

还有i-1-(j-1) = i-j个元素是满足ak<k的那么我们把新加的值和这些元素交换就可以使得值加一使值变成j了,共有i-j中交换方式所以 dp[i-1][j-1] * (i-j)

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1001;
long long dp[maxn][maxn];
const long long mod = 1e9+7;
int main(){
    int n,k;
    for(int i = 1; i <= 1000; i++){
        dp[i][0] = 1;
        for(int j = 1; j < i; j++){
            dp[i][j] = (dp[i-1][j] + dp[i-1][j] * j + dp[i-1][j-1] * (i - j)) % mod;
        }
    }
    while(scanf("%d%d",&n,&k) != EOF){
        printf("%lld\n",dp[n][k]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值