The Longest Straight FZU - 2216 (枚举左端点+二分右端点)

The Longest Straight

FZU - 2216

ZB is playing a card game where the goal is to make straights. Each card in the deck has a number between 1 and M(including 1 and M). A straight is a sequence of cards with consecutive values. Values do not wrap around, so 1 does not come after M. In addition to regular cards, the deck also contains jokers. Each joker can be used as any valid number (between 1 and M, including 1 and M).

You will be given N integers card[1] .. card[n] referring to the cards in your hand. Jokers are represented by zeros, and other cards are represented by their values. ZB wants to know the number of cards in the longest straight that can be formed using one or more cards from his hand.


Input

The first line contains an integer T, meaning the number of the cases.

For each test case:

The first line there are two integers N and M in the first line (1 <= N, M <= 100000), and the second line contains N integers card[i] (0 <= card[i] <= M).

Output

For each test case, output a single integer in a line -- the longest straight ZB can get.

Sample Input
2
7 11
0 6 5 3 0 10 11
8 1000
100 100 100 101 100 99 97 103
Sample Output
5
3

题意:有n张牌,这些牌的数字在1-m之间,其中如果牌的数字是0代表大王,可以变成任何1-m的数字,问用这n张牌可以构成的最长的连续上升序列是多少(1 2 3 4 5前后数字只相差1)

思路:用前缀和记录1-m中前i个数字中有多少个它没有,也就是前i个数字中我们需要几个0,从头记录到尾,而且我们记录下我们有的零的个数,然后每次枚举左端点从1-m一次枚举,然后巧妙运用upper_bound查找范围从i-最后,查找的值就是zero+左端点之前需要的零(因为是从头记录的嘛)减去左端点地址就得到了当前最大长度,然后每次比较得到总的最长长度

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100005;
int n,m,zero;
int sum[maxn];//前缀和用于记录前i个数字中有多少个数字没有
int card[maxn];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        zero = 0;
        memset(sum,0,sizeof(sum));
        memset(card,0,sizeof(card));
        scanf("%d%d",&n,&m);
        for(int i = 0; i < n; i++){
            int x;
            scanf("%d",&x);
            if(!x) zero++;
            else card[x] = 1;
        }
        for(int i = 1; i <= m; i++){
            sum[i] = sum[i-1] + (!card[i]);//记录没有的牌的个数
        }
        int ans = 0;
        for(int i = 1; i <= m; i++){//枚举左端点
            int len = upper_bound(sum + i,sum + 1 + m,zero + sum[i-1]) - (sum + i);
            //upper_bound查找第一个大于查找值的位置,所以第一个大于查找值位置减去起始位置恰好就是满足题意的值的长度
            //从sum+i开始到sum+1+m最后查找,我们想要找有zero个空缺的一个长度,而因为我们记录的是前缀和是从头开始的,所以我们查找的值实际是zero+之前的sum[i-1]
            ans = max(ans,len);
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值