Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Note
An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13.
题意:
给你一个数n,a+b=n,a<=b(a,b为素数),问有多少种这样的组合方法。
思路:
这个题可以直接采用埃式筛法打表,然后暴力搜索。
代码:
#define N 10000005
#include<map>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,k[700000];
bool book[N];
int main()
{
memset(book,false,sizeof(book));
book[0]=true;
for(int i=2; i<=N-5; i++)//打表
if(!book[i])
for(int j=2; j*i<=N-5; j++)
book[i*j]=true;
int l=0;
for(int i=2; i<=N-5; i++)//保存素数,为了使暴力搜索的时间缩短
if(!book[i])k[l++]=i;
int T,Case=1;scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int sum=0;
for(int i=0; k[i]<=n/2; i++)//k[i]本身是素数
if(!book[n-k[i]])sum++;//如果n-k[i]也是素数
printf("Case %d: %d\n",Case++,sum);
}
return 0;
}