FatMouse's Speed (贪心+最长严格符合条件子序列DP+路径还原)

FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
Output Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7

题意:给定 n 只老鼠,每只老鼠有体重和速度,求老鼠的一个最长序列,使得体重严格递增,速度严格递减。给出这个序列的长度,并且输出这个序列中的每只老鼠在输入中的序号。


解题思路:先对所有老鼠排序,第一个关键字体重从小到大,第二关键字速度从大到小。然后求这个序列中的严格符合之前排序条件的最长子序列。
dp[i] 记录以 i 只老鼠作为结尾的最长合法序列的长度,则有状态转移方程 dp[i]=max{dp[j]+1},0<=j<i。

最后输出时,因为我们每一步都是通过之前的某个状态+1得来的,那么我们往回找的时候就可以从最终的最长长度开始,往前找看哪一个状态可以+1得到当前状态,一直这样找到最开始,将答案存在vector中,然后倒叙输出每个老鼠的原本id编号

很好的一个题目!

code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct node{
    int w,s,id;
    bool operator < (const node &other)const{
        if(w != other.w)
            return w < other.w;
        return s > other.s;
    }
}m[1005];
int dp[1005];

int main(){
    int i,j,k;
    for(i = 0; i < 1005; i++){
        dp[i] = 1;
    }
    for(i = 1; cin >> m[i].w >> m[i].s; i++){
        m[i].id = i;
    }

    sort(m+1,m+i);
    int maxd = 1;
    for(j = 2; j < i; j++){
        for(k = 1; k < j; k++){
            if(m[k].w < m[j].w && m[k].s > m[j].s){
                dp[j] = max(dp[k] + 1,dp[j]);
                if(dp[j] > dp[maxd])
                    maxd = j;
            }
        }
    }
    cout << dp[maxd] << endl;

    vector<int> pos;
    pos.push_back(maxd);
    for(j = maxd-1; j >= 1; j--){
        if(dp[maxd] == dp[j]+1){
            pos.push_back(j);
            maxd = j;
        }
    }
    for(j = pos.size()-1; j >= 0; j--){
        cout << m[pos[j]].id << endl;
    }
    return 0;
}



  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值