Phalanx (dp求最大对称子矩阵)

Phalanx

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

Input There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0. Output Each test case output one line, the size of the maximum symmetrical sub- matrix.
Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0
Sample Output
3
3

题意:
给你一个n*n的矩阵,求矩阵的最大反对角线对称的子矩阵的长度。

分析:

由于长度为k的对称矩阵一定包含了一个长度为k-1的对称矩阵,即长度为k的矩阵可以有长度为k-1的矩阵推出来。所以形成了子问题。
我们如何表示一个状态呢?
设dp[i][j] = k,表示左下角坐标为(i,j)长度为k的对称矩阵。
然后我们从“极限状态”出发,当长度为1时,矩阵都为对称矩阵。我们从右上角往左下角方向枚举 ,dp[i][j] 可由dp[i-1][j+1] 推出来。所以直接dp即可。

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 1005;
char a[maxn][maxn];
int dp[maxn][maxn];

int main(){
    int n,ans;
    while(scanf("%d",&n) != EOF && n){
        ans = 1;
        for(int i = 0; i < n; i++){
            scanf("%s",a[i]);
        }
        //从右上角开始枚举
        for(int i = 0; i < n; i++){
            for(int j = n-1; j >= 0; j--){
                dp[i][j] = 1;
                if(i == 0 || j == n-1) continue;//在边缘长度只能为1
                int k = dp[i-1][j+1];
                for(int s = 1; s <= k; s++){
                    //因为长度为k+1的对称矩阵一定包含了长度为k的对称矩阵,所以判断时只需要判断最外圈是否对称即可
                    if(a[i-s][j] == a[i][j+s]) dp[i][j]++;
                    else break;
                }
                ans = max(ans,dp[i][j]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值