Find Integer HDU - 6441(费马大定理+勾股数)

Find Integer HDU - 6441

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn a n + b n = c n
.
Input
one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000)
;

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5
题意:

给定 n,abcan+bn=cn n , a 输 出 b , c 满 足 a n + b n = c n

无解输出-1 -1

分析:

观察可得n=0的时候无解

根据费马大定理可知 n3 n ≥ 3 时无解

因此只需要考虑n=2的情况,即勾股数

这里有一个结论:

对于大于2的任意偶数2n(n>1),都可构成一组勾股数,三边分别是:

2nn21n2+1 2 n 、 n 2 − 1 、 n 2 + 1

任意一个大于1的奇数2n+1(n>1)为边也可以构成勾股数,其三边分别是:

2n+12n2+2n2n2+2n+1 2 n + 1 、 2 n 2 + 2 n 、 2 n 2 + 2 n + 1

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        ll n,a;
        scanf("%lld%lld",&n,&a);
        if(n >= 3 || n == 0)
            printf("-1 -1\n");
        else if(n == 1)
            printf("%lld %lld\n",a,a*2);
        else{
            ll tmp;
            if(a & 1){
                tmp = (a - 1) / 2;
                printf("%lld %lld\n",tmp*tmp*2+tmp*2,tmp*tmp*2+tmp*2+1);
            }
            else{
                tmp = a / 2;
                printf("%lld %lld\n",tmp*tmp-1,tmp*tmp+1);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值