Find Integer

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

 

 

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

 

 

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

 

 

Sample Input

 

1 2 3

 

 

Sample Output

 

4 5

 

费马大定理:

 

一.当整数n>2时,关于xyz不定方程

x^n + y^n =z^n.

的整数解都是平凡解,即

当n是偶数时:(0,±m,±m)或(±m,0,±m)

当n是奇数时:(0,m,m)或(m,0,m)或(m,-m,0)

 

二. 给出x,求解n==2是的情况

1. 当x是奇数时y,z差值为1;

2.当x是偶数时y,z插值为2。

#include<stdio.h>
#include<iostream>
using namespace std;
#define ll long long int
int main()
{
	int t;
	scanf("%d",&t);
	ll n,a,b,c;
	while(t--)
	{
		scanf("%lld%lld",&n,&a);
		//费马大定理:n>2时a,b,c无同时大于零的解
		if(n>2||n==0)
		{
			printf("-1 -1\n");
		 }
		 else if(n==1)
		 {
		 	printf("1 %lld\n",a+1);
		  }
		  else{
		  	if(a%2==1)
		  	{
		  		b=a*a/2;	
		  		printf("%lld %lld\n",b,b+1);
			  }
			  else{
			  	b=a*a/4;
			  	printf("%lld %lld\n",b-1,b+1);
			  }
		   } 
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值