Ellipsoid HDU - 5017(模拟退火)

Ellipsoid HDU - 5017

 Given a 3-dimension ellipsoid(椭球面)

这里写图片描述
your task is to find the minimal distance between the original point (0,0,0) and points on the ellipsoid. The distance between two points (x 1,y 1,z 1) and (x 2,y 2,z 2) is defined as
这里写图片描述
Input
There are multiple test cases. Please process till EOF.

For each testcase, one line contains 6 real number a,b,c(0 < a,b,c,< 1),d,e,f (0 ≤ d,e,f < 1), as described above. It is guaranteed that the input data forms a ellipsoid. All numbers are fit in double.

Output
For each test contains one line. Describes the minimal distance. Answer will be considered as correct if their absolute error is less than 10 -5.
Sample Input

1 0.04 0.01 0 0 0

Sample Output

1.0000000

模拟退火法

确实是第一次做这种题,也第一次学习了这个算法,想学习可以看这篇博客

传送门

code:

#include <bits/stdc++.h>
using namespace std;
const int inf = 1e8;
const double eps = 1e-8;
const int dx[8] = {0,0,1,-1,1,-1,1,-1};
const int dy[8] = {1,-1,0,0,1,1,-1,-1};
double a,b,c,d,e,f;
//计算距离
double dis(double x,double y,double z){
    return sqrt(x * x + y * y + z * z);
}
//求解方程的新的z值
double calz(double x,double y){
    double A = c;
    double B = d * y + e * x;
    double C = f * x * y + a * x * x + b * y * y - 1.0;
    double delta = B * B - 4.0 * A * C;
    if(delta < 0.0) return inf + 10.0;
    delta = sqrt(delta);
    double z1 = (-B + delta) / (2.0 * A);
    double z2 = (-B - delta) / (2.0 * A);
    if(dis(x,y,z1) < dis(x,y,z2))
        return z1;
    return z2;
}
//模拟退火
double solve(){
    double x = 0, y = 0, z = sqrt(1.0 / c);
    double step = 1.0, rate = 0.99;//以rate的速率递减寻找的范围
    while(step > eps){
        for(int k = 0; k < 8; k++){
            double nx = x + step * dx[k];
            double ny = y + step * dy[k];//得到新的xy值
            double nz = calz(nx,ny);//由此得到新的z值
            if(nz >= inf) continue;//无解跳过
            if(dis(nx,ny,nz) < dis(x,y,z)){//如果新解比旧解更有,直接接受
                x = nx;
                y = ny;
                z = nz;
            }
        }
        step *= rate;//之后以更小的移动概率寻找新解
    }
    return dis(x,y,z);
}
int main(){
    while(~scanf("%lf%lf%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f)){
        printf("%.7f\n",solve());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值