求组合数 Lightoj1067

                                                           Combinations

 Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

题意求C_{n}^{k}

费马小定理求逆元除法取模,打表算阶乘。(不打表会TLE)

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
typedef long long ll;
const int MOD=1000003;
const int maxn=1e6+5;
int t;
long long n,k;
long long a[maxn];
long long b[maxn];
ll quickpow(ll a,ll b)
{
    ll ans=1;
    while(b)
    {
        if(b&1) ans=(ans*a)%MOD;
        a=(a*a)%MOD;
        b>>=1;
    }
    return ans;
}

int main()
{
    cin>>t;
    int cas=1;
    a[0]=1;
    b[0]=1;
    for(int i=1;i<=maxn-5;++i)
    {
        a[i]=(a[i-1]*i)%MOD;
        b[i]=quickpow(a[i],MOD-2);
    }
    while(t--)
    {
        scanf("%d%d",&n,&k);
        long long ans=(a[n]*b[k])%MOD;
        ans=(ans*b[n-k])%MOD;
        //cout<<a[n-k]<<' '<<a[k]<<endl;
        printf("Case %d: ",cas++);
        printf("%lld\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值