UVA 120 Stacks of Flapjacks

38 篇文章 0 订阅
9 篇文章 0 订阅

Background
Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.
This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.
The Problem
Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake’s diameter. All pancakes in a stack have different diameters.
Sorting a stack is done by a sequence of pancake “flips”. A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.
A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.
For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):
8 7 2
4 6 5
6 4 8
7 8 4
5 5 6
2 2 7
The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).
The Input
The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.
The Output
For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.
Sample Input
1 2 3 4 5
5 4 3 2 1
5 1 2 3 4
Sample Output
1 2 3 4 5
0
5 4 3 2 1
1 0
5 1 2 3 4
1 2 0

题意:
给你一叠薄煎饼,请你写一个程序来指出要如何安排才能使这些薄煎饼由上到下依薄煎饼的半径由小到大排好。所有的薄煎饼半径均不相同。要把薄煎饼排好序需要对这些薄煎饼做翻面(flip)的动作。方法是以一抹刀插入一叠薄煎饼中,然后做翻面的动作(也就是说在抹刀上面的薄煎饼经翻面后,会依相反的次序排列)。若一叠共有n个薄煎饼,我们定义最底下的薄煎饼的位置为1,最上面的薄煎饼位置为n。当抹刀插入位置为k时,代表从位置k到位置n的薄煎饼要做翻面的动作。一开始时,这叠薄煎饼随意堆放,并以半径大小来表示。
按照题目所给的方法排序并输出排序的过程。
题目的排序方法就是每次可以任意选个地方然后从头开始到这个地方翻转一下,
题目中的编号是逆序的即第一个为n最后一个为1
如5 1 2 3 4
先选取第一个就是从4到开头翻转变为4 3 2 1 5然后选第二个1然后翻转下1 2 3 4 5.

思路:
由于要求从小到大升序排列 ,所以,每次先找到未排序中最大的,将其翻到第一个,然后再把它翻到未排序的末尾。排序过程为先大后小,将大的不断放到末尾。
类似于选择排序,每次把要排的那个数字先翻转到开头,然后选择末尾第一个未排序的翻转,这样这个元素就排好位置了。
特殊情况:
1.数组中只有一个数
2.当前未排序数中最大的已经在首位
3.还未循环至最后,数组已经排列好

#include <iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int num[31];//储存初始顺序
void invert(int j)//翻转饼,即数组指定部分逆序,这一部分可用栈来实现
{
    int k,n;
    for(k=0;k<=j/2;k++)
    {
        n=num[k];
        num[k]=num[j-k];
        num[j-k]=n;
    }
}
int findMax(int n,int m)//找到数组中未排列好的数的最大值
{
    int i;
    for(i=0;i<n;i++)
    {
        if(num[i]==m)
            return i;
    }
    return 0;
}
int main()
{
    int final[31]={0};//储存数组最终顺序
    int i,n,j,k;
    int max;
    char ch;
    while(cin>>num[0])
    {
        n=1;
        ch=getchar();
        if(ch==' ')//特殊情况,数组中只有一个数
        {
        while(cin>>num[n++])
        {
            ch=getchar();
            if(ch=='\n')
                break;
        }
        }
    for(i=0;i<n-1;i++)
    {
        final[i]=num[i];
        cout<<num[i]<<" ";
    }
        final[i]=num[i];
        cout<<num[i]<<endl;
        sort(final,final+n);//对final数组进行排序,默认为升序
        for(k=n-1;k>=0;k--)//从最大开始循环
        {
            max=final[k];//当前最大值
            {
                j=findMax(n,max);//得到乱序数组中最大值的位置
                for(i=0;i<=j;i++)
                {
                    if(num[i]!=final[i])//若已经排好,则不翻转
                    {
                        invert(j);//将乱序数组中最大值翻转至首位
                        cout<<n-j<<" ";
                        invert(k);//将未排列好的部分逆序
                        cout<<n-k<<" ";
                        break;
                    }
                }
            }
        }
        cout<<"0"<<endl;
    }
    return 0;
}

注意:
翻转煎饼部分,即数组逆序,可用栈来实现

// stack::push/pop
#include <iostream>       // std::cout
#include <stack>          // std::stack

int main ()
{
  std::stack<int> mystack;

  for (int i=0; i<5; ++i) mystack.push(i);

  std::cout << "Popping out elements...";
  while (!mystack.empty())
  {
     std::cout << ' ' << mystack.top();
     mystack.pop();
  }
  std::cout << '\n';

  return 0;
}

Output:
Popping out elements… 4 3 2 1 0

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值