The Development Of Simulation Campus Network Based On Cisco Packet Tracer

Outline

In this project, I need to apply some related knowledge about networks, such as the configuration of switch and router, to establishing the simulation campus network. This is my individual undergraduate internship project from June 2017 to July 2017 and in this internship experience, I won the “Excellent Intern” award.

Screenshot

在这里插入图片描述

DormitoryNetwork segmentEngineering BuildingsNetwork segmentTeaching BuildingsNetwork segmentDining HallsNetwork segment
bldg.110.1.8.0/24bldg.110.1.2.0/24bldg.110.1.1.0/24new hall f.110.1.25.0/24
bldg.210.1.9.0/24bldg.210.1.2.0/24bldg.210.1.1.0/24new hall f.210.1.26.0/24
bldg.310.1.10.0/24bldg.310.1.2.0/24bldg.310.1.1.0/24new hall f.310.1.27.0/24
bldg.410.1.11.0/24bldg.410.1.2.0/24bldg.410.1.1.0/24old hall f.110.1.28.0/24
bldg.510.1.12.0/24bldg.510.1.2.0/24bldg.510.1.1.0/24old hall f.210.1.29.0/24
bldg.610.1.13.0/24bldg.610.1.2.0/24bldg.610.1.1.0/24old hall f.310.1.30.0/24
bldg.710.1.14.0/24bldg.710.1.2.0/24
bldg.810.1.15.0/24
bldg.910.1.16.0/24
bldg.1010.1.17.0/24
bldg.1110.1.18.0/24
bldg.1210.1.19.0/24
bldg.1310.1.20.0/24
bldg.1410.1.21.0/24
bldg.1510.1.22.0/24
bldg.1610.1.23.0/24
bldg.1710.1.24.0/24
Administration BuildingNetwork segmentLibraryNetwork segmentDMZNetwork segment
1&2 floor10.1.5.0/241&2 floor10.1.3.0/2410.4.1.0/24
3&4 floor10.1.6.0/243&4 floor10.1.4.0/24
5&6 floor10.1.7.0/24

Environment

Cisco Packet Tracer:
It is an auxiliary learning tool released by Cisco, which provides a network simulation environment for beginners learning Cisco network courses to design, configure, and troubleshoot network failures. Users can directly use the drag-and-drop method on the graphical user interface of the software to establish a network topology and can provide detailed processing of data packets traveling in the network, and observe the real-time operation of the network. You can learn IOS configuration and exercise troubleshooting capabilities.

https://baike.baidu.com/item/Cisco%20Packet%20Tracer/1423859?fr=aladdin

Protocol

VTP ( VLAN Trunking Protocol ) :
It is a Cisco proprietary protocol. Since many switches are in the network of the company, the workload of the VLAN configuration is heavy. You can use the VTP protocol to configure one switch as a VTP server, and the other switches as VTP clients, so that they can automatically learn the VLAN information on the server.
LACP ( Link Aggregation Control Protocol ) :
It is a layer 2 control protocol that can be used to automatically detect, configure, and manage, as one logical link, multiple physical links between two adjacent LACP enabled devices.
NAT ( Network Address Translation ) :
It is a technology that reconnects the IP address or destination IP address when an IP data packet passes through a router or firewall. This technique is commonly used in private networks that have multiple hosts but only access through one public IP address. It is a convenient and widely used technology.
EIGRP ( Enhanced Interior Gateway Routing Protocol ) :
It combines the Link State and Distance Vector Routing Protocol of Cisco’s proprietary protocol. It uses the DUAL to achieve rapid convergence. Periodic routing update information will not be sent to reduce bandwidth occupation. It supports Appletalk, IP, Novell And NetWare, and other network-layer protocols.

Reference:
https://baike.baidu.com/item/VTP/2235627?fr=aladdin
https://wiki.wireshark.org/LinkAggregationControlProtocol
https://baike.baidu.com/item/网络地址转换/2985755?fr=aladdin
https://baike.baidu.com/item/EIGRP/321594?fr=aladdin

Configuration

  1. Configure the vtp of all three-layer switches into 2 server mode and 7 client mode respectively:
vtp domain XGD
vtp mode client(server)
vtp password cisco
(vtp version 2)
  1. Configure all trunks. Trunking is used to connect different switches to ensure that the pc in the same VLAN which is divided by switches can communicate with each other. The port for these switches to connect is Trunk port. VLAN means a group of logical devices and users, and these devices and users are not restricted by physical location.

    For three-layer switch:

       switchport trunk encapsulation dotlq

For two-layer switch:

        switchport  mode trunk
  1. Apply LACP protocol to the core three-layer switch.
        channel-protocol lacp
        channel-group 12 mode active
  1. The network of the core three-layer switch on the left hand is divided into VLAN 8,9,10. The network of the core three-layer switch on the right hand is divided into VLAN 1 to 5. The network of the administrative building is divided into VLAN 6,7. The network of DMZ is VLAN 11. Take the configuration of VLAN 2 as an example:
		int vlan 2
		ip add 10.1.1.254 255.255.255.0 --(gateway+ subnet mask)
  1. Use computer to simulate a network segment, and configure VLAN for the corresponding layer 2 switch according to the division of each area.
		switchport mode access
		switchport access vlan 1
  1. Hot backup gateway technology, another gateway is prepared and when a gateway is broken down, the backup gateway will work instead. Here, I configure redundant networks belonging to the administrative building and DMZ area on the two core three-layer switches, namely VLAN 6, 7, 8. The standby gateway of VLAN 6, 8 is the three-layer switch on the right. The standby gateway of vlan7 is the three-layer switch on the left. Steps of configuration are as follows:
      	int vlan 8
		ip add 10.4.1.252 255.255.255.0
		standby 1 ip 10.4.1.254
		standby 1 preempt  
		standby 1 priority 200
		standby 1 track f0/1  

Configuration of back-up gateway:

		int vlan 8
		ip add 10.4.1.253 255.255.255.0
		standby 1 ip 10.4.1.254
		standby 1 preempt
		standby 1 priority 191
		standby 1 track f0/1
  1. Spanning tree technology, which means when a loop occurs in the network, the protocol can use a spanning tree algorithm to logically disconnect one of the connections, making it a backup line.
		spanning-tree mode pvst
		spanning-tree vlan 8 priority 0

Configure the spanning tree of a backup gateway:(4096 is the second smallest)

		spanning-tree mode pvst
		spanning-tree vlan 8 priority 4096

  1. Do EIGRP declaration of two core three-layer switches and all routers to achieve eigrp topology of the whole network
		router eigrp 100
		no auto-summary
		network (subnet) (anti-mask) 
  1. Configure NAT to achieve the access from the external network to the internal network.

Result

When a message has been sent between two computers, I can track it and obtain the following results.

Advantage

  1. Realize the hot backup gateway technology to improve the security and reliability of the administrative building and DMZ network;
  2. Each building has at least one switch, so as to reduce the line length and reduce the line overhead, to achieve the purpose of saving labor costs;
  3. Use the NAT protocol to control access to the external network to ensure safety.

In short, the modules are complete, safe, and reliable, and cost-effective.

Conclusion

In this blog, I mainly introduced my campus network design and showed some main steps of how to configure. In addition, in this project, I find the basic knowledge of the network is really important, that is, to figure out what function a network component can do rather than just remember the command lines to configure. During the process of configuration, more patience is needed to check every step of configuration when some problem occurs in the system. In the future, I will study more theory knowledge about the network to reinforce my ability and design a more secure network from a more comprehensive perspective. Thanks for reading!

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
The availability of multigigabit campus switches from Cisco presents customers the opportunity to build extremely high-performance networks with high reliability. Gigabit Ethernet and Gigabit EtherChannel® provide the high-capacity trunks needed to connect these gigabit switches. If the right network design approach is followed, performance and reliability are easy to achieve. Unfortunately, some alternative network design approaches can result in a network with lower performance, reliability, and manageability. With so many features available, and with so many permutations and combinations possible, it is easy to go astray. This paper is the result of Cisco’s experience with many different customers and it represents a common sense approach to network design that will result in simple, reliable, manageable networks. The conceptual approach followed in this paper has been used successfully in routed and switched networks around the world for many years. This hierarchical approach is called the “multilayer design.” The multilayer design is modular and capacity scales as building blocks are added. A multilayer campus intranet is highly deterministic, which makes it easy to troubleshoot as it scales. Intelligent Layer 3 services reduce the scope of many typical problems caused by misconfigured or malfunctioning equipment. Intelligent Layer 3 routing protocols such as Open Shortest Path First (OSPF) and Enhanced Interior Gateway Routing Protocol (EIGRP) handle load balancing and fast convergence. The multilayer model makes migration easier because it preserves the existing addressing plan of campus networks based on routers and hubs. Redundancy and fast convergence to the wiring closet are provided by Hot Standby Router Protocol (HSRP). Bandwidth scales from Fast Ethernet to Fast EtherChannel and from Gigabit Ethernet to Gigabit EtherChannel. The model supports all common campus protocols. The multilayer model will be described, along with two main scalability options appropriate for building-sized networks up to large campus networks. Five different backbone designs with different performance and scalability are also presented. In this paper the term backbone is used to represent the switches and links in the core of the network through which all traffic passes on its way from client to server.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值