HDOJ1863 畅通工程 最小生成书裸题

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32086    Accepted Submission(s): 14163


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
 

Sample Input
  
  
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

Sample Output
  
  
3 ?
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1879  1233  1875  1232  1102 

图还是比较稀疏的,用kruskal算法。记得每次都要合并两个节点的根,因为有可能数据中可以构成好几个小环,但彼此不连通。
#include <iostream>
#include <cmath>
#include <ctime>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 1e4+10;
const int maxm = 105;
struct node{
     int x,y,cost;
}a[maxn];

bool cmp(node p ,node q){
    return p.cost<q.cost;
}

int n,m,i,j,k,tot,MIN;
int root[maxm];

void Merge(int p ,int q){ //合并两个节点
    int z;
    while (root[p] != p) p=root[p];
    while (q!=root[q]) {
        z=root[q];
        root[q]=p;
        q=z;
    }
    root[q]=p;
}

int Find(int p){ //寻找根节点
    int z=p;
    while (root[z]!=z) z=root[z];
    return z;
}

void kruskal(){
   for (i=1; i<=n; i++) {
       if (Find(a[i].x) != Find(a[i].y)) { //比较根节点
           MIN += a[i].cost;
           Merge(a[i].y,a[i].x);
       }
   }
}

int main(){
    std::ios::sync_with_stdio(false);
    while ( cin >> n >> m && n){
        for (i=1; i<=n; i++) cin >> a[i].x >> a[i].y >> a[i].cost;
        sort(a+1,a+n+1,cmp);
        tot = MIN = 0;
        for (i=1; i<=m; i++) root[i]=i;

        kruskal();
        for (i=1; i<=m; i++) if (root[i] == i) tot++;
        if  (tot!=1) cout << '?' << endl;
        else cout << MIN << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值