编译工具各种报错(步骤正确,代码正确,配置正确)均可认为无解,除非...

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/confusing_awakening/article/details/80321261

程序猿见到上帝:各种编译报错
这里写图片描述
1.JAVA SSH三大框架配置时各种编译不通过
这里写图片描述
以前尝试过各种百度、谷歌、stackoverflow,均无解,怀疑猿生
最后瞎折腾,更换各种jar包版本,终于得解:
一般是由于jar包版本不匹配,需要集成版本相互匹配的所有jar包
这里写图片描述
2.Android Studio 使用原始方法配置JNI ,低版本运行时异常

4.4Android系统手机运行时报错:

java.lang.UnsatisfiedLinkError: dlopen failed: 
cannot locate symbol "__register_atfork" referenced by "libjni.so"...

这里写图片描述

以前尝试过各种百度、谷歌、stackoverflow,均无解,怀疑猿生
最后瞎折腾,更换各种NDK版本,终于得解:
一般是由于NDK版本和Android Studio版本不匹配,需要集成版本相互匹配的NDK

2.Android Studio 使用Cmake配置JNI ,编译不通过

Error: executing external native build for cmake 
C:\Users\PC1\Desktop\ndkdata\GDNdkText\app\CMakeLists.txt
CMake Error at D:/AndroidSDK/ndk-
bundle/build/cmake/android.toolchain.cmake:312 (message):

这里写图片描述

以前尝试过各种百度、谷歌、stackoverflow,均无解,怀疑猿生
最后瞎折腾,更换各种NDK版本,终于得解:
一般是由于NDK版本和Android Studio版本不匹配,需要集成版本相互匹配的NDK

总结:

编译工具奇葩报错,一般可以认为无解,除非…
编译工具各种版本必须相互匹配,一般原则是:高版本匹配高版本,低版本匹配低版本

这里写图片描述

GitHub

关注专题Android开发常用开源库

简书

微信公众号
这里写图片描述

QQ群
这里写图片描述

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页