列出叶节点(PAT3-2)

参考:http://www.patest.cn/contests/mooc-ds/03-2

问题:


时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:(注意输入没有顺序,而且每一行是,子节点索引,例如 2 7 表示这个节点的左边子节点为第二行的节点(0 -),右边子节点为第七行的节点(4 6)

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
4 1 5
实际树结构如下






#include "stdafx.h"
#include <stdio.h>
#include <stdlib.h>


#define MAXSIZE 16


typedef struct TNode{
struct TNode *left;
struct TNode * right;
int isFirst;             //isRoot node
int data;
}TNode;




typedef struct Queue
{
    TNode* node[MAXSIZE];
  int  top ,bottom;
  int size;


}Queue;


Queue* initQueue(Queue* queue)
{
queue->top=queue->bottom=0;         //开始都为0位置
queue->size=MAXSIZE;
//printf("bottom=%d\n",Queue->top);
return queue;
}
void push(Queue* queue, TNode* p)
{


  queue->node[queue->bottom]=p;
   queue->bottom++;


}
TNode* pop(Queue* queue)  //p is a pointer to pointer ,nice design
{


   TNode* ret=queue->node[queue->top];
   queue->top++;
     
     return ret;


}




bool isEmpty(Queue* queue){


    if(queue->top==queue->bottom)
        return true;
    return false;
}


TNode * list[MAXSIZE];
TNode * inputTNode(TNode *bt)
{


if(bt==NULL)
    bt=(TNode*)malloc(sizeof(TNode));
  char s[3],u[3];
        scanf("%s%s",u,s);
        if(s[0]=='-')
            bt->right=NULL;
        else
{
bt->right=(TNode*)malloc(sizeof(TNode));
            bt->right->data=atoi(s);
}
        if(u[0]=='-')
           bt->left=NULL;
        else
{
bt->left=(TNode*)malloc(sizeof(TNode));
             bt->left->data=atoi(u);
}




return bt;
}


TNode * initBTree()
{
TNode* bt=NULL;
int num,i;
scanf("%d",&num);
if(num==-1)
return NULL;
for(i=0;i<num;i++)
{
bt=(TNode*)malloc(sizeof(TNode));
list[i]=bt;
bt=inputTNode(bt);




}


for(i=0;i<num;i++)
{
TNode* bt=NULL;
bt=list[i];
//printf("bt value %d\n",bt->data);
if(bt->left)
{int tmp=bt->left->data;
bt->left=list[tmp];
bt->left->data=tmp;
printf("bt value %d\n",bt->left->data);
bt->left->isFirst=1;
}
if(bt->right)
{int tmp=bt->right->data; 
bt->right=list[bt->right->data];
bt->right->data=tmp;
bt->right->isFirst=1;
printf("bt value %d\n",bt->right->data);
}




}
TNode* root=NULL;
for(i=0;i<num;i++)
{
root=list[i];
if(root->isFirst!=1) break;
}


return root;
}










int main(int argc, char* argv[])
{
// Queue.top=-1;
    Queue queue;
Queue *q=&queue;
q=initQueue(q);
TNode * root=initBTree();
push(q,root);
    int first=1;
    while(!isEmpty(q))
    {
        TNode * tmp=pop(q);
        
        if((tmp->right==NULL)&&(tmp->left==NULL))
        {
            if(first)
            {
                first=0;
                printf("%d",tmp->data);
            }
            else
                printf(" %d",tmp->data);
        }
        if(tmp->left)
            push(q,tmp->left);
        if(tmp->right)
            push(q,tmp->right);
    }
return 0;
}


评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值