Consider a closed world and a set of features that are defined for all the objects in the world. Each feature can be answered with ``yes" or ``no". Using those features, we can identify any object from the rest of the objects in the world. In other words, each object can be represented as a fixed-length sequence of booleans. Any object is different from other objects by at least one feature.
You would like to identify an object from others. For this purpose, you can ask a series of questions to someone who knows what the object is. Every question you can ask is about one of the features. He/she immediately answers each question with ``yes" or ``no" correctly. You can choose the next question after you get the answer to the previous question.
You kindly pay the answerer 100 yen as a tip for each question. Because you don't have surplus money, it is necessary to minimize the number of questions in the worst case. You don't know what is the correct answer, but fortunately know all the objects in the world. Therefore, you can plan an optimal strategy before you start questioning.
The problem you have to solve is: given a set of boolean-encoded objects, minimize the maximum number of questions by which every object in the set is identifiable.
Input
The input is a sequence of multiple datasets. Each dataset begins with a line which consists of two integers,m and n: the number of features, and the number of objects, respectively. You can assume0 < m11 and0 < n128. It is followed byn lines, each of which corresponds to an object. Each line includes a binary string of lengthm which represent the value (``yes" or ``no") of features. There are no two identical objects.
The end of the input is indicated by a line containing two zeros. There are at most 100 datasets.
Output
For each dataset, minimize the maximum number of questions by which every object is identifiable and output the result.
Sample Input
8 1 11010101 11 4 00111001100 01001101011 01010000011 01100110001 11 16 01000101111 01011000000 01011111001 01101101001 01110010111 01110100111 10000001010 10010001000 10010110100 10100010100 10101010110 10110100010 11001010011 11011001001 11111000111 11111011101 11 12 10000000000 01000000000 00100000000 00010000000 00001000000 00000100000 00000010000 00000001000 00000000100 00000000010 00000000001 00000000000 9 32 001000000 000100000 000010000 000001000 000000100 000000010 000000001 000000000 011000000 010100000 010010000 010001000 010000100 010000010 010000001 010000000 101000000 100100000 100010000 100001000 100000100 100000010 100000001 100000000 111000000 110100000 110010000 110001000 110000100 110000010 110000001 110000000 0 0
Sample Output
0 2 4 11 9
题目意思真是难懂。。。一开始以为是最少询问几个特征,每询问一个特征那个人会把所有物体有没有那个特征告诉你,问最少询问多少个问题就可以区分所有物体。结果题目不是这个意思。。意思是给你一个东西,你先问这个东西有没有这个特征,他回答YES或NO,然后如果你没判断出这个东西是哪个的话,可以问第二个问题,有没有另外一个特征,他再回答。
也就是不管他回答什么,求最坏情况最少要问多少次可以知道这个东西是什么。
用quest表示目前已经问了哪些问题,1代表问过,answer表示目前他给的答案,1代表YES,DP(quest,answer)代表当前状态下还需要再问几个问题。如果用a[i]表示第i个物体的特征,那么quest&a[i]如果和answer相等的话,就说明第i个物体满足当前的回答。如果这个物体不超过1个,就判断出来这个物体了,不需要再问了。如果超过一个,那肯定还要根据其他特征来判断。在还没问的问题中选择问题,在回答这个问题是YES和NO中选答案较大的一个(因为i是最坏情况),看是否能更新当前最小值。
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<sstream>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define INF 0x3f3f3f3f
#define MAXN 130
#define MAXM 12
#define eps 1e-9
#define pi 4*atan(1.0)
#define pii pair<int,int>
using namespace std;
int M,N;
char str[MAXM];
int a[MAXN],d[1<<MAXM][1<<MAXM];
int DP(int quest,int answer){
int &ans=d[quest][answer];
if(ans!=-1) return ans;
int cnt=0;
for(int i=0;i<N;i++) if((quest&a[i])==answer) cnt++;
if(cnt<=1) return ans=0;
ans=INF;
for(int i=0;i<M;i++) if((quest&(1<<i))==0) ans=min(ans,max(DP(quest|(1<<i),answer),DP(quest|(1<<i),answer|(1<<i)))+1);
return ans;
}
int main(){
freopen("in.txt","r",stdin);
while(scanf("%d%d",&M,&N),M||N){
memset(a,0,sizeof(a));
for(int i=0;i<N;i++){
scanf("%s",str);
for(int j=0;j<M;j++) if(str[j]=='1') a[i]|=(1<<j);
}
memset(d,-1,sizeof(d));
printf("%d\n",DP(0,0));
}
return 0;
}