hdu2196 Computer 树形DP 树上点到其它点的最远距离

Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4

  一棵树,求每个点到其它点的最远距离。

  一个节点的最远距离的第一步只有两种情况,一种是到它子树,一种是到它父节点。

  dp[u][0]代表u到以u为根的树的最远距离,dp[u][1]代表u到以u为根的树的第二远距离,这两个用一次DFS可以求出来。dp[u][2]表示经过父节点的最远距离。经过父节点的最远距离怎么求?一种是父节点再到它的父节点,还有一种是父节点到它的子节点,如果父节点到子树的最远距离路径不经过当前点,那就是最远距离,否则要用第二远距离。再用一次DFS求出来。最后在dp[u][0]和dp[u][2]里取小的。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
#define eps 1e-9
#define INF 0x3f3f3f3f
#define MAXN 10010
#define MAXM 100010
#define MAXNODE 100010*4
#define MOD 999983
typedef long long LL;
using namespace std;
int N,dp[MAXN][3];
vector<pair<int,int> >G[MAXN];
void DFS1(int u,int fa){
    int len=G[u].size(),first=0,second=0;
    for(int i=0;i<len;i++){
        int v=G[u][i].first,w=G[u][i].second;;
        if(v!=fa){
            DFS1(v,u);
            if(dp[v][0]+w>first){
                second=first;
                first=dp[v][0]+w;
            }
            else if(dp[v][0]+w>second) second=dp[v][0]+w;
        }
    }
    dp[u][0]=first;
    dp[u][1]=second;
}
void DFS2(int u,int fa){
    int len=G[u].size();
    for(int i=0;i<len;i++){
        int v=G[u][i].first,w=G[u][i].second;
        if(v!=fa){
            dp[v][2]=max(dp[u][2],dp[v][0]+w==dp[u][0]?dp[u][1]:dp[u][0])+w;
            DFS2(v,u);
        }
    }
}
int main(){
    freopen("in.txt","r",stdin);
    while(scanf("%d",&N)!=EOF){
        for(int i=1;i<=N;i++) G[i].clear();
        int v,w;
        for(int u=2;u<=N;u++){
            scanf("%d%d",&v,&w);
            G[u].push_back(make_pair(v,w));
            G[v].push_back(make_pair(u,w));
        }
        DFS1(1,-1);
        dp[1][2]=0;
        DFS2(1,-1);
        for(int i=1;i<=N;i++) printf("%d\n",max(dp[i][0],dp[i][2]));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值