HDU 3172 Virtual Friends

B - Virtual Friends
Time Limit:2000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input

Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input

     
     
1 3 Fred Barney Barney Betty Betty Wilma
 

Sample Output

     
     
2 3 4
 


并查集+map+size数组

这题是我一定次使用STL里面的map,以前都是vector,queue,stack这些。手上的STL手册也没看完。不过做了这一题,总算是了解了map,以后也会用了。

STL的map用法和Java里的HashMap十分相似,说白了就是键值对。

比如这一题里要把string人名通过map映射到一个对应的int值,那么就可以定义如下:

 map<string,int> m;
再定义两个字符串:

char a[25];
那么

 m[a]=i;
就把a字符串映射到int类型的i上了,就可以开个数组上并查集了。

如果a字符串不在map里,那么m[a]对应的int值就是0,以此可以判断集合中是否已存在某一元素。


最后看AC源码

#include <stdio.h>
#include <iostream>
#include <map>
#define N 100005
using namespace std;
int fa[N];
int size[N];
int Find(int x) {
    return fa[x] == x ? x : fa[x] = Find(fa[x]) ;
}
bool Merge(int u ,int v) {
    int fu = Find(u) , fv = Find(v) ;
    if(fu != fv)
    {
        fa[fv] = fu ;
        size[fu]+=size[fv];
        size[fv]=0;
    }
        printf("%d\n",size[fu]);
    return fu != fv ;
}
int main()
{
    int t;
    while(scanf("%d",&t)>0)
    {
        while(t--)
        {
            map<string,int> m;
            for(int i=1; i<N; i++)
            {
                fa[i] = i;
                size[i]=1;
            }
            int n;
            scanf("%d",&n);
            int i=1;
            while(n--)
            {
                    char a[25],b[25];
                    scanf("%s%s",a,b);
                    if(m[a]==0)
                    {
                        m[a]=i;
                        i++;
                    }
                    if(m[b]==0)
                    {
                        m[b]=i;
                        i++;
                    }
                    Merge(m[a],m[b]);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值