POJ 3370 Halloween treats 鸽巢原理


Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6181 Accepted: 2281 Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source



有n个住户和c个小孩,每个住户会给小孩一些糖果,孩子为了让要来的糖果能够平分,则他们可以像哪些住户要糖果?

 s1=a1 s2=a1+a2....sn=a1+a2+...+an,这样一共有n个数,考虑他们除以c的余数,余数至多为 0...c-1 至多有c种,这就是说必然有si sj (i<j) 它们除c的余数是相同的,所以 sj-si能被c整除,sj-si= ai+1 + ai+2...+aj,所以这些数的和是c的倍数。

//1564K	2000MS
#include<stdio.h>
#include<algorithm>
#define M 100007
using namespace std;
int p[M];
long long sum;
struct sa
{
    int mod,num;
}s[M];
int cmp(sa a,sa b)
{
    if(a.mod==b.mod)return a.num<b.num;
    return a.mod<b.mod;
}
int main()
{
    int c,n;
    while(scanf("%d%d",&c,&n),c|n)
    {
        int k=-1,h;
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&p[i]);
            sum+=p[i];//对前i个数累加
            s[i].mod=sum%c;
            s[i].num=i+1;
            if(k==-1&&s[i].mod==0)k=i;//前i个数的和是c的倍数
        }
        if(k==-1)//没有找到这样的数列
        {
            sort(s,s+n,cmp);//所有和的余数从小到大排列
            for(int i=0;i<n-1;i++)
                if(k==-1&&s[i].mod==s[i+1].mod)//如果两个余数相等,则说明他们原来的和是c的倍数
                {
                    k=s[i].num;
                    h=s[i+1].num;
                }
            if(k==-1)printf("no sweets\n");
            else
            {
                for(int i=k+1;i<h;i++)
                    printf("%d ",i);
                printf("%d\n",h);
            }
        }
        else
        {
            for(int i=0;i<k;i++)
                printf("%d ",i+1);
            printf("%d\n",k+1);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值