HDU 2488 A Knight's Journey


A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23951 Accepted: 8094

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany



以字典序输出排序,则搜索方向就要按照特定的顺序排序,则第一个遍历的路径一定是字典序。DFS问题。很好。
#include<stdio.h>
#include<string.h>
int m,n,tot, flag;
int dir[8][2] {{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
int mark[27][27],stack[100][2];

void print()
{
    for(int b=1;b<=tot;b++)
    printf("%c%d",stack[b][0]+64,stack[b][1]);
    printf("\n");
}

void dfs(int num)
{
    int xx,yy,i,x,y,numn;
    if(num==tot&&!flag)
    {
        print();
        flag=1;
        return;
    }
    x=stack[num][0];
    y=stack[num][1];
    for(i=0; i<8; i++)
    if(!flag)
        {
           xx=x+dir[i][0];
           yy=y+dir[i][1];
           if((xx>0)&&(xx<=n)&&(yy>0)&&(yy<=m)&&mark[xx][yy]==0)
           {
               numn=num+1;
               stack[numn][0]=xx;
               stack[numn][1]=yy;
               mark[xx][yy]=1;
               dfs(numn);
               mark[xx][yy]=0;
           }
        }
        else return;
}

int main()
{
    int t,a;
    scanf("%d",&t);
    for(a=1; a<=t; a++)
    {
        scanf("%d%d",&m,&n);
        memset(mark,0,sizeof(mark));
        memset(stack,0,sizeof(stack));
        flag=0;
        tot=n*m;
        mark[1][1]=1;
        stack[1][0]=1;
        stack[1][1]=1;
        printf("Scenario #%d:\n",a);
        dfs(1);
        if(!flag)printf("impossible\n");
        printf("\n");
    }
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值