HDU 1068 Girls and Boys 求独立集(入门)

点击打开链接

 

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5793    Accepted Submission(s): 2592


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 


 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 


 

Sample Output
  
  
5 2
 


 

Source
 


 

Recommend
JGShining

 

 

题意是说男生和女生两两配对。让你求有多少人无法配对。就是求最大独立集,而最大独立集=定点数---最大匹配。因为此题的图是无向图,所以最大匹配还要除以2.如图2,就是此题的图。

 

#include<stdio.h>
#include<string.h>
using namespace std;
int n;
int link[1007],g[1007][1007];
bool vis[1007];
struct node
{
    int x,y,z;
}box[1007];
bool judge(int i, int j)
{
    if(box[i].x<box[j].x&&box[i].y<box[j].y&&box[i].z<box[j].z)
    return true;
    return false;
}
bool find(int i)
{
    for(int j=0;j<n;j++)
    if(g[i][j]&&!vis[j])
    {
        vis[j]=true;
        if(link[j]==0||find(link[j]))
        {
            link[j]=i;
            return true;
        }
    }
    return false;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(g,0,sizeof(g));
        memset(link,0,sizeof(link));
        int a,b,num;
        for(int i=0;i<n;i++)
        {
            scanf("%d: (%d) ",&a,&num);
            while(num--)
            {
                scanf("%d",&b);
                g[a][b]=1;
            }
        }
        int count=0;
        for(int i=0;i<n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i))
            count++;
        }
        printf("%d\n",n-count/2);
    }
    return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值