POJ-The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.


Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.


Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1

1

2003年3月中旬,严重急性呼吸综合征(SARS)是一种未知病因的非典型肺炎,被认为是全球性威胁。为了尽量减少对他人的传播,最好的策略是将嫌疑犯与其他人分开。
在不传播你的病态大学(NSYSU),有很多学生团体。同组中的学生经常互相交流,学生可以加入几个小组。为了防止SARS的传播,NSYSU收集所有学生组的成员名单,并在其标准操作程序(SOP)中作出以下规则。
一个团体中的一个成员是一个嫌疑人,该组中的所有成员都是嫌疑犯。
但是,他们发现,当学生被认定为嫌犯时,确定所有嫌犯是不容易的。你的工作是写一个查找所有嫌疑犯的程序。
输入
输入文件包含几种情况。每个测试用例从一行中的两个整数n和m开始,其中n是学生的数量,m是组的数量。您可以假设0 <n <= 30000,0 <= m <= 500.每个学生都使用0和n-1之间的唯一整数进行编号,最初学生0在所有情况下都被识别为嫌疑人。该行之后是组的成员列表,每组一行。每行以整数k开始,表示组中成员的数量。在成员数量之后,有k个整数表示这个组的学生。一行中的所有整数由至少一个空格隔开。
n = 0和m = 0的情况表示输入的结束,不需要处理。
输出
对于每种情况,输出一行中的嫌疑犯人数。
样品输入
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
样品输出
4
1
1


#include<stdio.h>
const int maxn=1e6+10;
int par[maxn];
void init(int n)//初始化 
{
	for(int i=0;i<n;i++)
	{
		par[i]=i;
	}
}
int find(int x)//查找并压缩 
{
	if(x!=par[x])
	return par[x]=find(par[x]);
}
void unite(int a,int b)//合并 
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
	par[fb]=fa;
}
int main()
{
	int n,m,num,maxn;
	while(scanf("%d %d",&n,&m),m+n)
	{
		init(n);
		while(m--)
		{
			int p,q;
			scanf("%d%d",&p,&q);
			for(int i=1;i<p;i++)
			{
				int r;
				scanf("%d",&r);
				unite(q,r);
				q=r;
			}
		}
				num=0;//与0所在相同时,num加1 
				int q=par[0];
				for(int i=0;i<=n-1;i++)
				if(find(i)==find(0))
				num++;
		printf("%d\n",num);
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值