HDU 1540 Tunnel Warfare

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones. 

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately! 
Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event. 

There are three different events described in different format shown below: 

D x: The x-th village was destroyed. 

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself. 

R: The village destroyed last was rebuilt. 
Output
Output the answer to each of the Army commanders’ request in order on a separate line. 
Sample Input
7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4
Sample Output
1
0
2
4
题意:n个点,m条语句,D v:表示毁坏v这个点,Q v:表示查询v这个点左右连续未毁坏点的个数,R:表示修复最近毁坏的点。拿样例解释,第一行7 9 代表7个点,9条语句,D 3; D 6; D 5,结果:  1 2 3 4 5 6 7,Q 4,由结果得知连续的点个数是1个; Q 5,由结果得知连续的点个数是0个,因为5节点本身就已经被毁坏。R ,结果: 1 2 3 4 5 6 7,Q 4,由结果得知连续的点的个数是2个;R,结果是: 1 2 3 4 5 6 7,Q 4,由结果得知连续的点的个数是4个。

#include <stdio.h>
const int maxn = 5*1e4+5;
struct Node{
	int left;
	int right;
	int numl, numr;
	int length;
	int mid() {
		return (left+right)>>1;
	}
}node[maxn<<2];
void Build(int i, int l, int r) {
	node[i].left = l;
	node[i].right = r;
	node[i].numl = r-l+1;
	node[i].numr = r-l+1;
	node[i].length = r-l+1;
	if(l == r) {
		return ;
	}
	int m = (l+r)>>1;
	Build(i<<1, l, m);
	Build(i<<1|1, m+1, r);
	return ;
}

void Update(int i, int v, int k) {
	if(node[i].left == node[i].right) {
		node[i].numl = node[i].numr = k;
		return ;
	}
	int m = node[i].mid();
	if(v <= m) Update(i<<1, v, k);
	else Update(i<<1|1, v, k);
	if(node[i<<1].numl+node[i<<1|1].numr == node[i].length) {
		node[i].numl = node[i].numr = node[i].length;
	}
	else {
		if(node[i<<1].numl == node[i<<1].length)
		node[i].numl = node[i<<1].length+node[i<<1|1].numl;
		else  node[i].numl = node[i<<1].numl;
		if(node[i<<1|1].numr == node[i<<1|1].length)
		node[i].numr = node[i<<1|1].length+node[i<<1].numr;
		else node[i].numr = node[i<<1|1].numr;
	}
}

int Query(int i, int v) {
	if(i == 1) {
		if(node[i].numl) {
			if((node[i].left + node[i].numl-1) >= v)
				return node[i].numl;
		}
		if(node[i].numr) {
			if((node[i].right - node[i].numr+1) <= v)
				return node[i].numr;
		}
	}
	if(node[i].numl) {
		if((node[i].left + node[i].numl-1) >= v)
			return node[i].numl+node[i-1].numr;
	}
	if(node[i].numr) {
		if((node[i].right - node[i].numr+1) <= v)
			return node[i].numr+node[i+1].numl;	
	}
	if(node[i].left == node[i].right) return 0;
	int m =node[i].mid();
	if(m >= v) return Query(i<<1, v);
	else return Query(i<<1|1, v);
}
int main() {
	char op;
	int n, m, v;
	int sta[maxn];
	while(~scanf("%d %d", &n, &m)) {
		Build(1, 1, n);
		int t = 0;
		for(int i = 1; i <= m; i++) {
			getchar();
			scanf("%c", &op);
			if(op == 'D') {
				scanf("%d", &v);
				sta[++t] = v; 
				Update(1, v, 0);
			}
			else if(op == 'Q') {
				scanf("%d", &v);
				printf("%d\n", Query(1, v));
			}
			else {
				if(t == 0) continue;
				int cnt = sta[t--];//ÐÞ¸´×î½ü»Ù»µµÄÒ»¸ö 
				Update(1, cnt, 1);
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值