HDU 1540 Tunnel Warfare xds

G - Tunnel Warfare
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones. 

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately! 
 

Input

The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event. 

There are three different events described in different format shown below: 

D x: The x-th village was destroyed. 

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself. 

R: The village destroyed last was rebuilt. 
 

Output

Output the answer to each of the Army commanders’ request in order on a separate line. 
 

Sample Input

       
       
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4
 

Sample Output

       
       
1 0 2 4
 

区间合并的题

被我xjb二分卡过去了


ACcode;

#include <cstdio>
#include <cstring>
#define tmp (st<<1)
#define mid ((l+r)>>1)
#define lson l,mid,tmp
#define rson mid+1,r,tmp|1
#define maxn 50002
#define len (r-l+1)
#define push_up(x) sum[x]=sum[tmp]+sum[tmp|1]
using namespace std;
int sum[maxn<<2],sta[maxn],top;
inline void build(int l,int r,int st){
    if(l==r){
        sum[st]=1;
        return ;
    }
    build(lson);
    build(rson);
    push_up(st);
}
inline void updata(int t,int add,int l,int r,int st){
    if(l==r){
        sum[st]=add;
        return ;
    }
    if(t<=mid)updata(t,add,lson);
    else updata(t,add,rson);
    push_up(st);
}
inline int query(int L,int R,int l,int r,int st){
    if(L<=l&&r<=R)return sum[st];
    int ret=0;
    if(L<=mid)ret+=query(L,R,lson);
    if(R>mid)ret+=query(L,R,rson);
    return ret;
}
int main(){
    int n,q,x;
    char str[4];
    while(~scanf("%d%d",&n,&q)){
        build(1,n,1);
        top=0;
        while(q--){
            scanf("%s",str);
            if(str[0]=='D'){
                scanf("%d",&x);
                updata(x,0,1,n,1);
                sta[++top]=x;
            }
            else if(str[0]=='R'&&top){
                    x=sta[top--];
                    updata(x,1,1,n,1);
            }
            else if(str[0]=='Q'){
                scanf("%d",&x);
                int ans=query(x,x,1,n,1);
                if(ans==0){
                    printf("0\n");
                    continue;
                }
                int l=1,r=x-1,t,k=0;
                while(l<=r){
                    t=query(mid,x-1,1,n,1);
                    if(t==x-mid){
                        k=x-mid;
                        r=mid-1;
                    }else l=mid+1;
                }
                ans+=k;
                l=x+1,r=n,k=0;
                while(l<=r){
                    t=query(x+1,mid,1,n,1);
                    if(t==mid-x){
                        k=mid-x;
                        l=mid+1;
                    }else r=mid-1;
                }
                ans+=k;
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}

花了一下午学了下区间合并

对于这道题来说查询到t的位置的时候要考虑t~mid或mid~t是否连续如果是的话需要查询连续的那一块

ACcode:


#include <cstdio>
#include <algorithm>
#include <cstring>
#define tmp (st<<1)
#define mid ((l+r)>>1)
#define lson l,mid,tmp
#define rson mid+1,r,tmp|1
#define maxn 50002
#define len (r-l+1)
using namespace std;
int sum[maxn<<2],sta[maxn],top,lsum[maxn<<2],rsum[maxn<<2];
inline void push_up(int st,int m){
    lsum[st]=lsum[tmp];
    rsum[st]=rsum[tmp|1];
    sum[st]=max(max(sum[tmp],sum[tmp|1]),lsum[tmp|1]+rsum[tmp]);
    if(lsum[st]==m-(m>>1))lsum[st]+=lsum[tmp|1];
    if(rsum[st]==m>>1)rsum[st]+=rsum[tmp];
}
inline void build(int l,int r,int st){
    sum[st]=lsum[st]=rsum[st]=len;
    if(l==r)return ;
    build(lson);
    build(rson);
}
inline void updata(int t,int add,int l,int r,int st){
    if(l==r){
        sum[st]=lsum[st]=rsum[st]=add;
        return ;
    }
    if(t<=mid)updata(t,add,lson);
    else updata(t,add,rson);
    push_up(st,len);
}
inline int query(int t,int l,int r,int st){
    if(l==r||sum[st]==0||sum[st]==len) return sum[st];
    if(t<=mid){
        if(t>=mid-rsum[tmp]+1)///如果t到mid连续要查询mid右边
            return query(t,lson)+query(mid+1,rson);
        else
            return query(t,lson);
    }
    else {
        if(t<=mid+1+lsum[tmp|1]-1 )///同理
            return query(t,rson)+query(mid,lson);
        else
            return query(t,rson);
    }
}
int main(){
    int n,q,x;
    char str[4];
    while(~scanf("%d%d",&n,&q)){
        build(1,n,1);
        top=0;
        while(q--){
            scanf("%s",str);
            if(str[0]=='D'){
                scanf("%d",&x);
                updata(x,0,1,n,1);
                sta[++top]=x;
            }
            else if(str[0]=='R'&&top){
                    x=sta[top--];
                    updata(x,1,1,n,1);
            }
            else if(str[0]=='Q'){
                scanf("%d",&x);
               printf("%d\n",query(x,1,n,1));
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值