数据结构 PAT 02-线性结构3 Pop Sequence

02-线性结构3 Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N(the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO


#include <stdio.h>
#include <stdlib.h>

/**
 *  栈的结构体
 */
struct StackNode
{
    int *data; // 存储元素的数组指针
    int top; // 栈顶指针
    int maxSize; // 堆栈最大容量
};
typedef struct StackNode *Stack;

/**
 *  栈的创建
 */
Stack stackCreate(int maxSize)
{
    Stack s = (Stack)malloc(sizeof(struct StackNode));
    s->data = (int *)malloc(maxSize *sizeof(int));
    s->top = -1;
    s->maxSize = maxSize;
    return s;
}

/**
 *  栈顶元素
 */
int top(Stack s)
{
    if (s->top == -1)
        return -1;
    return s->data[s->top];
}

/**
 *  压栈
 */
int push(Stack s, int x)
{
    if (s->top == s->maxSize-1)
        return -1;
    s->data[++(s->top)] = x;
    return 1;
}

/**
 *  出栈
 */
int pop(Stack s)
{
    if (s->top == -1)
        return -1;
    return s->data[(s->top)--];
}

int isPopSequence(int *popArray, int max, int n)
{
    int i, j;
    Stack s = stackCreate(max);
    j = 0;
    for (i = 1; i <= n; i++)
    {
        if (push(s, i) == -1) // 说明栈满
            return 0;
        while (top(s) == popArray[j]) //
        {
            pop(s);
            j++;
        }
    }
    if (j == n) // 栈中元素出尽
        return 1;
    else
        return 0;
}

int main()
{
    int M, N, K, i, j;
    scanf("%d %d %d", &M, &N, &K);
    int popArray[N]; // 存放每一行的序列
    int result[K]; // 存放结果
    
    for (i = 0; i < K; i++)
    {
        for (j = 0; j < N; j++)
            scanf("%d", &popArray[j]);
        result[i] = isPopSequence(popArray, M, N);
    }
    for (i = 0; i < K; i++)
    {
        if (result[i] ==1 )
            printf("YES\n");
        else if(result[i] ==0 )
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值