MOOC 数据结构 Pop Sequence

MOOC 数据结构 Pop Sequence

原题地址

题目描述

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, ..., NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:

YES
NO
NO
YES
NO

代码实现

#include<iostream>
#include<cstdio>
#include<stack>
using namespace std;

int main(){

   stack<int> s;
   int M,N,K;
   cin>>M>>N>>K;
   for(int i=0;i<K;i++){
     int tmp=1;
     bool flag=1;
     for(int j=0;j<N;j++){
        int input;
        cin>>input;
        while(s.size()<=M && flag){
           if(s.empty() || s.top()!=input){
              s.push(tmp++);
           }
           else if(s.top()==input){
               s.pop();
               break;
           }
           if(s.size()>M){
             flag=0;
             break;
           }
        }
      }
     if(flag)
        cout<<"YES"<<endl;
     else
        cout<<"NO"<<endl;
     while(!s.empty()){
        s.pop();
     }
   }
   return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值