Common Subsequence||HDU1159

Link:http://acm.hdu.edu.cn/showproblem.php?pid=1159

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

题解:找出两个字符串的最长公共子序列,可以去搜搜LCS(不是欧美联赛.)
AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[1005][1005],t;
char s1[1005],s2[1005];
int main()
{
    int l1,l2,i,j;
    while(~scanf("%s%s",s1+1,s2+1))
    {
        s1[0]=s2[0]='0';
        memset(dp,0,sizeof(dp));
        l1=strlen(s1);
        l2=strlen(s2);
//      t=1;
        for(i=1;i<l1;i++)
        {
            for(j=1;j<l2;j++)
            {
                if(s1[i]==s2[j])
                  dp[i][j]=dp[i-1][j-1]+1;
                else
                  dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
//          t=1-t;
        }
        printf("%d\n",dp[l1-1][l2-1]);
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

三更鬼

谢谢老板!

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值