PAT 1150 Travelling Salesman Problem

原题链接:1150 Travelling Salesman Problem (25分)
参考的柳神博客:PAT 1150 Travelling Salesman Problem(25 分)- 甲级

关键词:图、模拟

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:
n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

题目大意: 模拟:给出图并给出若干条路径,判断路径是这个图的旅行商环路、简单旅行商环路还是非旅行商环路。

简单回路:图的顶点序列中,除了第一个顶点和最后一个顶点相同外,其余顶点不重复出现的回路叫简单回路

代码:

#include <iostream>
#include <vector>
#include <set>
using namespace std;

int e[210][210];
vector<int> route;
int n, m, k; //城市数量、无向图中边的数量、路线的数量
int ans = 0x3f3f3f, ansid;  //ansid最短的路线编号

void check(int index) {
    int sum = 0, cnum, flag = 1;    //cnum路线中的城市数 flag是否满足旅行商环路
    scanf("%d", &cnum);  
    
    set<int> s;
    vector<int> v(cnum);
    
    for (int i = 0; i < cnum; i ++ ) {
        scanf("%d", &v[i]);
        s.insert(v[i]); //放入set中
    }
    for (int i = 0; i < cnum - 1; i ++ ) {
        if(e[v[i]][v[i + 1]] == 0) flag = 0;    //连续的两个点不可达,不满足旅行商环路
        sum += e[v[i]][v[i+1]];
    }
    if (flag == 0) {
        printf("Path %d: NA (Not a TS cycle)\n", index);    //不可达就没有总距离
    } 
    else if(v[0] != v[cnum-1] || s.size() != n) {   //第一个结点和最后一个结点不同
        printf("Path %d: %d (Not a TS cycle)\n", index, sum);
    } 
    else if(cnum != n + 1) {    //旅行商环路,但不满足访问源点两次
        printf("Path %d: %d (TS cycle)\n", index, sum);
        if (sum < ans) {
            ans = sum;
            ansid = index;
        }
    }
    else {  //简单旅行商环路,即满足访问过n+1个结点(源点访问两次)
        printf("Path %d: %d (TS simple cycle)\n", index, sum);
        if (sum < ans) {
            ans = sum;
            ansid = index;
        }
    }
}

int main(){

    scanf("%d%d", &n, &m);
    
    for(int i = 0; i < m; i ++ ){
        int a, b, dist;
        scanf("%d%d%d", &a, &b, &dist);
        e[a][b] = e[b][a] = dist;
    }
    
    scanf("%d", &k);    //给定路径的数量
    for(int i  = 1; i <= k; i ++ ) check(i);
    
    printf("Shortest Dist(%d) = %d\n", ansid, ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值