PAT 1032 Sharing

原题链接:1032 Sharing (25分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意:

如果两个单词拥有共同的后缀,那么可以让它们共享一个相同的子链表。
现在有两个链表各自代表一个单词,他们的后缀是相同的,要求找到第一个相同的结点,并返回它的地址。

方法一:静态链表+遍历

思路:

用结构体来存储结点,对于第一个单词的字母将flag标记为1,然后遍历第二个单词的链表,当第一次遇到结点的flag为1时即为所求,若是没有则输出-1。

C++ 代码:

#include <iostream>
using namespace std;

const int maxn = 100010;

struct node{
    int next;
    char data;
    bool flag = false;    // 判断是否在第一个链表中出现
}nodes[maxn];

int main(){
	int h1, h2, n;    // h1、h2两个链表的其实地址 n总结点数
    scanf("%d %d %d", &h1, &h2, &n);
    
    int addr, next;    // addr地址 next下一结点地址
	char data;
    
    // 读入所有结点 
    while(n--){
        scanf("%d %c %d", &addr, &data, &next);
        nodes[addr].data = data;
        nodes[addr].next = next;
    }

    int ans = -1;
    
    // 标记链表1中的结点 
    for(int p = h1; p != -1; p = nodes[p].next){
        nodes[p].flag = true;
    }
    
    // 遍历链表2中的结点 
    for(int q = h2; q != -1; q = nodes[q].next){
        if(nodes[q].flag == true){
            ans = q;
            break;
        }
    }
    
    if(ans == -1)
        printf("-1\n");
    else
        printf("%05d", ans);
    
    return 0;
}

复杂度分析:

  • 时间复杂度:O(n),最多遍历每个结点一次
  • 空间复杂度:O(maxn),实际上开了一个足够大的数组用于存储静态链表

测试点3:

其中一个单词为空的情况,此时需要输出-1

输入:

11111 -1 1
11111 a -1

输出:

-1

补充:

  • 使用%05d格式输出,可以使不足五位的地址高位补0;
  • scanf使用%c格式时候是会读入空格的,因此在输入地址、数据、下一结点地址时,需要写成%d %d %d必须加空格
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值