PAT 1160 Forever

原题链接:PAT 1160 Forever(20)
关键词:DFS+剪枝

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor(除数) of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

题目大意: 找到满足条件的“永久数”
思路: DFS的时候需要剪枝。提前判断出肯定取不到结果的情况。

  1. DFS的时候设置当前所在第i位,i从1~9进行循环(A的位数最多9位),sum为当前情况下的位数的总和,rest_k为剩下的位数;
  2. 递归边界的条件是rest_k为0,且满足sum = m,此时将结果放入ans;
  3. 当剩余的rest_k位全部取9,sum也到不了m或者说当前的各位数的和sum已经超过了m是肯定不会有结果的,剪去;
  4. 否则进行递归到i的下一位:DFS(A*10 + i, sum+i, rest_K-1);

网上大佬发现的数学规律:满足条件的永远是后k-2位都是9,前两位则是是和为m- 9*(k-2) 的组合。

代码:

#include<cstdio> 
#include<algorithm> 
#include<vector> 
using namespace std;
struct node{
	int n, A;	//n A+1各个位数之和 A求的数 
};
int n,m,N,k;
vector<node> ans;

bool cmp(node a,node b){	//按照n递增排序,n相同按照A递增排序 
	if(a.n != b.n) return a.n < b.n;
	else return a.A < b.A;
}

bool isPrime(int x){	//判断是不是大于3的素数 
	if(x <= 2) return false;
	for(int i = 2; i * i<= x; i++)
		if(x % i == 0) return false;
	return true;
}

int gcd(int a,int b){	//求最大公约数 
	return b == 0 ? a : gcd(b,a%b);
}
int digit_sum(int A){	//各个位数之和 
	int sum = 0;
	while(A){
		sum += A%10;
		A/=10;
	}
	return sum;
}

void DFS(int A, int sum, int rest_K){	//A目标数 sum当前位数和 rest_k剩余k位 
	if(rest_K == 0){	//递归边界 
		if(sum == m){
			int n = digit_sum(A + 1);
			if(isPrime(gcd(m, n)))
				ans.push_back({n, A});
		}
	}
	else if(rest_K > 0){
		for(int i = 0; i <= 9; i++){
			//如果当前位为i,即时剩余的rest_k - 1位全部取9也无法达到m,则剪枝
			//当前位数和sum,当前位取i,已经超过了m也剪枝 
			if(sum + i + (rest_K-1)*9 >= m && sum + i <= m)
				DFS(A*10 + i, sum+i, rest_K-1);
		}
	}
}

int main(){
	scanf("%d",&N);	//样例数 
	for(int x = 1; x <= N; x++){
		ans.clear();
		printf("Case %d\n",x);
		scanf("%d%d",&k,&m);	//k A的位数, m A各位数之和 
		
		for(int i = 1; i <= 9; i++)	//i是当前位数 
			DFS(i, i, k-1);
			
		if(ans.empty()){
			printf("No Solution\n");
			continue;
		}
		sort(ans.begin(), ans.end(), cmp);
		for(int i = 0; i < ans.size(); i++){
			printf("%d %d\n",ans[i].n, ans[i].A);
		}
	} 
	return 0;
}

用到的小工具:

bool isPrime(int x){	//判断是不是大于3的素数 
	if(x <= 2) return false;
	for(int i = 2; i * i<= x; i++)
		if(x % i == 0) return false;
	return true;
}

int gcd(int a,int b){	//求最大公约数 
	return b == 0 ? a : gcd(b,a%b);
}

int digit_sum(int A){	//各个位数之和 
	int sum = 0;
	while(A){
		sum += A%10;
		A/=10;
	}
	return sum;
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值