PAT 1134 Vertex Cover

原题链接:1134 Vertex Cover (25分)
关键词:图、模拟

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

题目大意:
如果图中的一个顶点集合能够满足图中的每一条边都至少有一个端点在该集合内,那么这个顶点集合就是图的顶点覆盖。
现在给定一张图,以及若干个顶点集合,请你判断这些顶点集合是否是图的顶点覆盖。

代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e4 + 5;
int n, m;
vector<int> g[maxn];
set<pair<int, int>> all;

int main() {
    //freopen("in.txt", "r", stdin);
    ios::sync_with_stdio(false);
    cout.tie(NULL);
    cin >> n >> m;
    for(int i = 0; i < m; ++i) {
        int u, v;
        cin >> u >> v;
        all.insert({u, v});
        all.insert({v, u});
        g[u].push_back(v);
        g[v].push_back(u);
    }
    int k;
    cin >> k;
    while(k--) {
        int t;
        cin >> t;
        set<pair<int, int>> vis;
        for(int i = 0; i < t; ++i) {
            int u;
            cin >> u;
            for(auto v : g[u]) {
                vis.insert({u, v});
                vis.insert({v, u});
            }
        }
        if(vis.size() == all.size()) cout << "Yes" << endl;
        else cout << "No" << endl;
    }
    return 0;
}

注意:需要将cin加速,否则会超时,需要在主函数开头加入以下代码:

    ios::sync_with_stdio(false);
    cout.tie(NULL);

AcWing yxc的代码:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;
const int maxn = 10000 + 10;
struct node{	//边 
    int a,b;
}edg[maxn];
int n, m, k;	//n顶点数 m边数 k询问数 
bool st[maxn];

string func(){
      for(int i = 0; i < m; i++){
            if(!st[edg[i].a] && !st[edg[i].b]) 
            return "No";
      }
      return "Yes";
}

int main(){
    cin >> n >> m;
    for(int i = 0; i < m; i++) cin >> edg[i].a >> edg[i].b;
    cin >> k;
    while(k--){
        int q;	//顶点数 
		cin >> q;
        memset(st, false, sizeof st);
        while(q--){
            int w;
			cin >> w;
            st[w] = true;
        }
      cout<< func() <<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值