PAT甲级1134 Vertex Cover

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104 ), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:
Nv v[1] v[2]⋯v[Nv]
where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

题目大意

给出一张无向图图,再给出一些结点,判断给出的几个结点和这些结点相关的边能不能绘制出图上所有的边

思路

给每条边从0~M-1编号,输入时每给出边的两个端结点,就将这个边的编号放入两个端结点各自的集合。后面给出结点时就将这个结点集合中的所有边编号设为true。最后从0到M-1遍历,只要发现不是true的就说明没有包含图上的所有边,输出No即可

#include <iostream>
#include <cstdlib>
#include <vector>
#include <climits>
using namespace std;
int N, M, K;
vector<int> Adj[10005];
bool vis[10005];
bool judge();
int main()
{
	cin >> N >> M;
	for (int i = 0; i < M; i++)
	{
		int a, b;
		cin >> a >> b;
		//边编号放入端点的集合中
		Adj[a].push_back(i);
		Adj[b].push_back(i);
	}
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		if (judge())
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
	system("pause");
	return 0;
}
bool judge()
{
	//注意要初始化,因为judge要多次调用
	for (int i = 0; i < M; i++)
		vis[i] = false;
	int Nv;
	cin >> Nv;
	for (int i = 0; i < Nv; i++)
	{
		int node;
		cin >> node;
		//Adj[node][j]表示结点node相关的边,全部设为true
		for (int j = 0; j < Adj[node].size(); j++)
			vis[Adj[node][j]] = true;
	}
	for (int i = 0; i < M; i++)
		if (vis[i] == false)
			return false;
	return true;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值