PAT 1076 Forwards on Weibo (30分)

原题链接:1076 Forwards on Weibo (30分)
关键词:BFS、图

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意: 一个人发微博,可能会被关注他的人转发,现在给定一个微博关注关系图和最大转发的层数,问你最大转发数是多少。

分析:

  1. 题目给的是用户的关注列表,转发是指a发的微博可能被关注a的人转发,边的方向不要搞混;
  2. 在常规BFS的基础上增加的一个层数,因此需要设置结构体,BFS的过程中如果到下一层就让layer+1,判断的条件要加上next.layer <= l,在这个基础上对cnt进行计数;

代码:

// pat 1076

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1010; 
int n, l;	//用户数 最大层数

struct node{
	int id, layer;	//编号 层数 
}; 

vector<node> adj[maxn];	//邻接表 
bool inq[maxn] = {false};

int bfs(int st, int l){	//起点 层数上限
	int cnt = 0;	//转发数 
	queue<node> q;
	
	node start;
	start.id = st;
	start.layer = 0;
	
	q.push(start);	//起点入队 
	inq[start.id] = true;
	
	while(!q.empty()){
		node topnode = q.front();
		q.pop();
		int u = topnode.id;	//取出队首的编号
		for(int i = 0; i < adj[u].size(); i++){
			node next = adj[u][i];
			next.layer = topnode.layer+1;
			if(!inq[next.id] && next.layer <= l){	//之前未入队且层数不大于最大层数
				q.push(next);
				inq[next.id] = true;	
				cnt++;			
			}
		} 
	}
	return cnt;
}

int main(){
//	freopen("in.txt", "r", stdin);
//	freopen("out.txt", "w", stdout);
	
	node user;	//用户 
	scanf("%d%d", &n, &l);
	for(int i = 1; i <= n; i ++ ){
		user.id = i;	//用户的编号i 
		int num;	//i关注的人数 
		scanf("%d", &num);

		for(int j = 0; j < num; j ++){
			int id;	//关注的人的id 
			scanf("%d", &id);
			adj[id].push_back(user);	//边: id->i 
		}
	}
	
	int k, st;	//询问数 起点 
	scanf("%d", &k);
	for(int i = 0; i < k; i ++ ) {
		memset(inq, false, sizeof(inq));	//inq的初始化 
		
		scanf("%d", &st);
		
		int ans = bfs(st, l);
		printf("%d\n", ans);
	}
		
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值