PAT 1029 Median(25分)

原题连接:PAT 甲级 1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105 ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

方法一:归并

思路:

将两个有序数组合并,合并后的中位数就是下标为 (m+n)/2 的元素

C++代码:

#include <iostream>
using namespace std;

const int maxn = 2e5 + 10;
int a[maxn], b[maxn], c[2 * maxn];
int n, m;

int main(){
    // 读入两个数组
    scanf("%d", &n);
    for(int i = 0; i < n; i++ ) scanf("%d", &a[i]);
    
    scanf("%d", &m);
    for(int j = 0; j < m; j++ ) scanf("%d", &b[j]);
    
    // 归并的过程 k是C数组下标 ij为双指针
    int i = 0, j = 0, k = 0;
    while(i < n && j < m){
        if(a[i] <= b[j]) c[k++] = a[i++];
        else c[k++] = b[j++];
    }
    
    // 扫尾
    while(i < n) c[k++] = a[i++];
    while(j < m) c[k++] = b[j++];
    
    // 偶数时 中位数为最中间两个数中小的那一个
    printf("%d", c[(m + n - 1) / 2]);
    
    return 0;
}

复杂度分析:

  • 时间复杂度:O(m+n) ,归并需要遍历每个数组(但题目中m和n其实都在N的范围内,写O(N)也没错)
  • 空间复杂度:O(m+n) ,需要一个临时数组存放所有元素

方法二:减治法

C++代码:

#include <bits/stdc++.h>
using namespace std;

const int N = 200010;
int a[N], b[N], n, m;

// 输出第k小的数 i和j为可删除的第一个位置
int findKth(int a[], int i, int b[], int j, int k){
    if(i == n) return b[j + k - 1];
    if(j == m) return a[i + k - 1];
    if(k == 1) return min(a[i], b[j]);

    int mid1 = i - 1 + k / 2 < n ? a[i - 1 + k / 2] : INT_MAX;
    int mid2 = j - 1 + k / 2 < m ? b[j - 1 + k / 2] : INT_MAX;
    if(mid1 < mid2) return findKth(a, i + k / 2, b, j, k - k / 2);//删除后的第一个位置传入递归函数
    else return findKth(a, i, b, j + k / 2, k - k / 2);
}

int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i ++) scanf("%d", &a[i]);
    
    scanf("%d", &m);
    for(int i = 0; i < m; i ++) scanf("%d", &b[i]);
    
    // 中位数就是合并后第l大的数
    int l = (m + n + 1) / 2;
    printf("%d", findKth(a, 0, b, 0, l));
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值