PAT 1041 Be Unique(20分)

原题链接:PAT 1041 Be Unique(20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10 4 ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105 ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目大意:

给你若干个数,返回第一个出现的只出现过一次的数,没有这样的数就返回None

方法一:计数

思路:

用a[n]存储读入的数,同事多开一个数组m[n]用于记录a[i]出现的次数。遍历一遍存数,再遍历一遍将结果输出。

C++ 代码:

// pat 1041 
#include <iostream>
using namespace std;

const int maxn = 1e5 + 10;

int a[maxn], m[maxn];
int n;

int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++ ){
        scanf("%d", &a[i]);
        m[a[i]]++;
    }

    bool flag = 0;
    for(int i = 0; i < n; i++ ){
        if(m[a[i]] == 1){
            printf("%d", a[i]);
            flag = 1;
            break;
        }
    }

    if(!flag)
        printf("None");
    
    return 0;
}

复杂度分析:

  • 时间复杂度:O(n),遍历两遍数组
  • 空间复杂度:O(n),两个数组,数组最大长度为1e5
  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值