PAT 1100 Mars Numbers(20分)

原题链接:PAT 1100 Mars Numbers(20分)

People on Mars count their numbers with base 13:

  • Zero on Earth is called “tret” on Mars.
  • The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.

For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:
For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

题目大意:

火星上的数字是13进制,同时给出了低位数字的火星文形式以及高位数字的火星文形式,题目要求做到地球和火星文的转换

方法一:数组

思路:

首先判断是否是数字来区分是将火星文转换为地球文还是相反。
接下来就是模拟了。

C++ 代码:

// pat 1100 Mars Numbers 

#include<iostream>
#include<cstring>
#include<map>
using namespace std;

int n;
string str;

// 代表低位和高位的两个字符串数组 
string l[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};
string h[13]={"tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};

// 地球转火星 
void etom(int num){
	if(num < 13)
		cout << l[num];
	else{
		cout << h[num / 13];
		if(num % 13 != 0){
			cout << " ";
			cout << l[num % 13];
		}
	} 
	cout << endl;
}

// 火星转地球 
void mtoe(string s){
	int ans = 0;
	string n1 = s.substr(0,3), n2;
	if(s.length() > 4)
		n2 = s.substr(4,3);
		
	for(int i = 1; i < 13; i++){
		if(n1 == h[i]) ans += 13 * i;
		if(n1 == l[i] || n2 == l[i]) ans += i;
	}
	cout << ans << endl;
} 

int main(){
    scanf("%d\n", &n);	// 这里需要读入\n 
    for(int i = 0; i < n; i++){
        getline(cin, str); // 读入一行 
        if(isdigit(str[0]))	
            etom(stoi(str));
        else
            mtoe(str);
    }

    return 0;
}

测试点2和4:

当数字是13的倍数,也就是余数为0的情况
例如:

1
26

结果应该是 hel 而不是 hel tret

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值