pat1108Finding Average

                                     1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Yinstead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    string str;
    cin>>n;
    double sum=0.0;
    int num=0;
    for(int i=0;i<n;i++)
    {
        cin>>str;
        int f=0;
        for(int i=0;i<str.length();i++)
            if(!(str[i]>='0'&&str[i]<='9'||str[i]=='.'||str[i]=='-'))///不满足
                {
                   cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
                    f=1;
                    break;
                }
        if(count(str.begin(),str.end(),'.')>1)
        {
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            continue;
        }
        if(f==0)///满足条件
        {
            if(count(str.begin(),str.end(),'.')==1)
            {
                int loc=str.find(".");
                if(str.length()-loc-1>2)
                {
                    cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
                    continue;
                }
            }
            float shu=atof(str.c_str());
            if(shu<-1000||shu>1000)
            {
                cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
                    continue;
            }
            sum+=shu;
            num++;
        }
    }
    if(num==1)
        printf("The average of 1 number is %.2f\n",sum/num);
    else if(num==0)
        printf("The average of 0 numbers is Undefined");
    else
        printf("The average of %d numbers is %.2f\n",num,sum/num);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值