HDU 1058 Humble Numbers—dp动态规划基础题

原题地址:http://acm.hdu.edu.cn/showproblem.php?pid=1058


Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16946    Accepted Submission(s): 7382


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

题意:找出第n个丑数,丑数的定义是只以2,3,5,7为因子的数,即num=(2^i)*(3^j)*(5^k)*(7^s)。

解题思路:n的上限是5842,题上的样例输出也给出了n取5842时的上限MAX=2000000000,所以要用longlong,接下来就是很简单的四重循环了,因为2^31>MAX,3^20>MAX,5^14>MAX,7^12>MAX,最多循环31*20*14*12是不会超时的,在每重循环都应该判断一下乘上当前的数是否超过MAX,超过就break,不然longlong也会爆掉。

输出的时候要格外注意,结尾是1,2,3要特殊讨论,还要注意结尾是11,12,13时的情况。


AC代码:

#include "iostream"
#include "algorithm"
#include "math.h"
using namespace std;
#define MAX 2000000000

int main()
{
	long long num2=1,num3=1,num5=1,num7=1,num[6000];
	int nnum=-1,n;
	for(int i2=0;i2<=30;i2++)
	{
		num2=(double)pow((double)2,(int)i2);
		for(int i3=0;i3<=19;i3++)
		{
			num3=(double)pow((double)3,(int)i3)*num2;
			if(num3>MAX)
				break;
			for(int i5=0;i5<=13;i5++)
			{
				num5=(double)pow((double)5,(int)i5)*num3;
				if(num5>MAX)
					break;
				for(int i7=0;i7<=11;i7++)
				{
					num7=(double)pow((double)7,(int)i7)*num5;
					if(num7>MAX)
						break;
					num[++nnum]=num7;
				}
			}
		}
	}
	sort(num,num+nnum+1);
	while(scanf("%d",&n)&&n)
	{
		if(n%10==1&&n%100!=11)
			printf("The %dst humble number is %lld.\n",n,num[n-1]);
		else if(n%10==2&&n%100!=12)
			printf("The %dnd humble number is %lld.\n",n,num[n-1]);
		else if(n%10==3&&n%100!=13)
			printf("The %drd humble number is %lld.\n",n,num[n-1]);
		else
			printf("The %dth humble number is %lld.\n",n,num[n-1]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值