HDU 1058 Humble Numbers (动规+寻找丑数问题)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16742    Accepted Submission(s): 7280



Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1176  1421  1024  1025  1081

大神找规律,我这种弱菜只能看别人代码了。。orz。
分别乘2,乘3,乘5,乘7,哪个小取哪个,乘过之后,p2,p3,p5,p7的值还要改变一下。。。其实就是一个光搜的过程,,,,题目。

每个数都可以分解成有限个2 3 5 7 的乘积,dp方程为dp[i]=f[i]=min(f[a]*2,min(f[b]*3,min(f[c]*5,f[d]*7)))

找到比f[i-1]大且最小的数,在这里用到了滚动查找;

下面详细解释:

a表示f[]数组中,下标为a的数*2 可能得到当前的 f[i];若是则++

b表示f[]数组中,下标为b的数* 3 可能得到当前的f[i];若是则++

c表示f[]数组中,下标为b的数* 5 可能得到当前的f[i];若是则++

d表示f[]数组中,下标为b的数* 7 可能得到当前的f[i];若是则++

求出他们中的min,则为f[i];


 如果一个数的质因子只有2357,那么这个数被称为Humble Numbers(差数)。将正整数正序排列(1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... )你会发现前20Humble Numbers(差数)。
    现在,你的任务是编写一个程序将第nHumble Numbers(差数)找出并打印出来。
    
输入规范:
输入的数有许多组,其中的n均满足1 <= n <= 5842。如果输入0,则表示终止。
输出规范:
对于每一组数,分列几行输出“The nth humble number is number.”,其中nth必须根据英语词法规范写为“1st2nd3rd4th5th6th7th8th9th10th... ”。
还用到英语。。。orz。
一般来说个位数是1为st,个位数为2是nd,个位数为3是rd;但是有例外,11, 12 ,13均为th,同时111,112,113均为th,除此之外,其他都是th;
代码:
#include <iostream>
#include <algorithm>
using namespace std;
#define M 50000
__int64 min(__int64 a,__int64 b,__int64 c,__int64 d){  
    __int64 x=a<b?a:b;  
    __int64 y=c<d?c:d;  
    return x<y?x:y;  
}  
__int64 vis[M];
int main(__int64 p2,__int64 p3,__int64 p5,__int64 p7)
{   
    int i=1,n,cur;
    p2=p3=p5=p7=1;
    memset(vis,0,sizeof(vis)); vis[1]=1;
    while(vis[i]<=2000000000)
    {
        vis[++i]=min(vis[p2]*2,vis[p3]*3,vis[p5]*5,vis[p7]*7);
        if(vis[i]==vis[p2]*2) p2++;  
        if(vis[i]==vis[p3]*3) p3++;  
        if(vis[i]==vis[p5]*5) p5++;  
        if(vis[i]==vis[p7]*7) p7++;  
    }
    while(scanf("%d",&n)!=EOF,n)
    {
        string ss;  
        if(n%10==1&&n%100!=11)  
            printf("The %dst humble number is %I64d.\n",n,vis[n]);  
        else if(n%10==2&&n%100!=12)  
            printf("The %dnd humble number is %I64d.\n",n,vis[n]);  
        else if(n%10==3&&n%100!=13)  
            printf("The %drd humble number is %I64d.\n",n,vis[n]);  
        else   
            printf("The %dth humble number is %I64d.\n",n,vis[n]);  
        
    }  
return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值