Python3.5.2爬虫框架库Scrapy安装,Twisted安装

Win7操作系统里Python的API更新不匹配真是坑爹啊,再加上API开发与Python的版本不一致。。。Twisted和Python3.5.2绝对是有仇。。。
本文主要记录Win7(64位)操作系统,Python3.5.2安装Scrapy库需要wheel库、Twisted库等,主要麻烦是Twisted库更新与wheel和Scrapy端口不匹配。。。

首先,去https://pypi.python.org/packages/source/T/Twisted/Twisted-15.2.1.tar.bz2下载个Twisted-15.2.1.tar,解压缩打开命令行,python setup.py install安装这个版本Twisted包

然后,再去Python官网,
或者Twisted开发官网http://twistedmatrix.com/trac/
或者http://www.lfd.uci.edu/~gohlke/pythonlibs/
下载个最新版Twisted-17.9.0.whl文件,pip安装更新twisted15.2.1包

最后,pip install Scrapy就可以了。

如果Twisted不在旧版本基础上更新安装,会缺少文件导致17.9.0的Twisted和基础wheel包不匹配;如果不更新Twisted会导致Scrapy与旧版本Twisted15.2.1的不匹配,因为缺少twisted.persisted模块包。。。。
这里写图片描述

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/cymy001/article/details/78220367
个人分类: Python爬虫
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭