POJ 3461 Oulipo(KMP详解)

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36962 Accepted: 14918

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


题解:一道KMP模板题,通过这道题可以很好地理解KMP
KMP很重要的一点就是原字符串的下标i永不回退,回退的是匹配的字符串的下标j
还有一点重要的的是next[k]数组,next[k]表示的是下标为k之前的子字符串中最长的前缀后缀相同的长度,那next数组有什么用那,用处就是在匹配字符失败的时候直接移动j来进行下一次匹配。
在这里推荐几篇能够讲清楚kmp的文章:

从头到尾彻底理解KMP:http://blog.csdn.net/v_july_v/article/details/7041827

接下来是AC code(不过跑得好慢):
import java.io.*;
import java.util.*;
public class Main {

	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();
		sc.nextLine();
		for(int o=1;o<=n;o++){
			String pat=sc.nextLine();
			String txt=sc.nextLine();
			int count=0;
			int[]next=makeNext(pat);//创建匹配字符串的next数组
			int t_length=txt.length();
			int p_length=pat.length();
			int j=0;
			for(int i=0;i<t_length;i++){
				while(j>0&&txt.charAt(i)!=pat.charAt(j)){
					j=next[j];//当匹配失败时,回退j
				}
				if(txt.charAt(i)==pat.charAt(j)){
					j++;//如果当前字符匹配,j++往后找
				}
				if(j==p_length){
					count++;
					j=next[j];//找到了,count++过以后将当作没有匹配到,回退j
				}
			}
			System.out.println(count);
		}

	}
	public static int[] makeNext(String s){
		int s_length=s.length();
		int[] next=new int [s_length+1];
		int j=0;
		int k=-1;
		next[0]=-1;
		while(j<s_length){
			if(k==-1||s.charAt(j)==s.charAt(k)){
				next[++j]=++k;
			}
			else
				k=next[k];
		}
		return next;
	}

}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值