A Bug's Life

sex保存异性,(a,b)    同性的在一个集合,a一定和sex[b]是同性的,b一定和sex[a]是同性的。

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 
Output

            The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
 
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


      
      
Hint
Huge input,scanf is recommended.
 
 
Source
TUD Programming Contest 2005, Darmstadt, Germany
 
Recommend
linle
 


#include<iostream>
using namespace std;
int bugs[4004];
int sex[2002];
bool isfind=false;
void init(int n)
{
for(int i=1;i<=n;i++)
{
  bugs[i]=-1;
  sex[i]=0;
 
}
isfind=false;


 
}
int parent(int a)
{
   while(bugs[a]>0)
   {
   
     a=bugs[a];
   }
   return a;




}


void combine(int a,int b)
{
   int p1=parent(a);
   int p2=parent(b);
   if(p1!=p2)
   {
      if(bugs[p1]>bugs[p2])
 {
   bugs[p1]=p2;
bugs[p2]--;
 
 
 }
 else
 {
    bugs[p2]=p1;
bugs[p1]--;
 
 }
   
   }






}
void equal(int a,int b)
{
   int p1=parent(a);
   int p2=parent(b);
   if(p1==p2)
   {
  isfind=true;
   return;
   }
  
  if(sex[a])combine(sex[a],b);
  if(sex[b])combine(sex[b],a);
  sex[a]=b;
  sex[b]=a;




}
int main()
{
//freopen("in.txt","r",stdin);
int n;
scanf("%d",&n);
int icase=1;
while(n--)
{
printf("Scenario #%d:\n",icase++);
   int num,inter;
scanf("%d%d",&num,&inter);
init(num);
for(int i=1;i<=inter;i++)
{
 int a,b;
 scanf("%d%d",&a,&b);
 
 
 if(!isfind)
 {
equal(a,b);
 
 }
 else{
   continue;
 
 }

}
if(isfind)
{
 printf("Suspicious bugs found!\n");

}
else
{
 printf("No suspicious bugs found!\n");
}
 
    printf("\n");
 



}
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
FileZilla Server 0.9.14a是FileZilla的一个服务器版本。这个版本存在一些bug,以下是一些常见的bug及解决方法: 1. 崩溃:在某些情况下,FileZilla Server 0.9.14a可能会因为一些内部错误而崩溃。要解决这个问题,可以尝试升级到最新版本的FileZilla Server,通常会修复此问题。 2. 无法连接:有时客户端可能无法连接到FileZilla Server。首先,请确保服务器正在运行,并且服务器的端口正确配置。如果问题仍然存在,可以尝试重新启动服务器,并检查防火墙设置。 3. 用户权限问题:有些用户可能报告无法正确访问或修改文件的权限。这可能是由于FileZilla Server的配置错误导致的。建议仔细检查用户的权限设置,确保用户具有所需的访问权限。 4. 传输中断:在某些情况下,传输可能会意外中断,导致文件传输不成功。这可能是由于网络连接不稳定或配置错误引起的。建议使用稳定的网络连接,并确保服务器的传输设置正确。 5. 界面错误:FileZilla Server 0.9.14a的界面可能偶尔出现错误或未响应。这可能是由于软件本身的问题。建议尝试重新启动FileZilla Server,并确保计算机的操作系统和其他软件都是最新版本。 总结来说,FileZilla Server 0.9.14a存在一些已知的bug,但大多数情况下可以通过更新到最新版本、检查配置设置或重启服务器来解决。在遇到问题时,还可以参考FileZilla的官方论坛或在线文档,以获得更多帮助和支持。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值