【PAT (Advanced Level)】1001. A+B Format (20)

1001. A+B Format (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

这个题目实现比较简单,关键在于输出数字的格式(','的添加和负数'-'的添加),代码采用将数字转换成字符,然后输出字符的方法;
代码如下:
/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
	/*ifstream cin;
	cin.open("in.txt");
	ofstream cout;
	cout.open("out.txt");*/
	//
	// TO DO Whatever You WANT!
	int a, b;
	while (cin >> a >> b)
	{
		int c = a + b;							// 计算
		bool flag = c < 0 ? true : false;				// 符号标记
		list<char>s;							// 字符串容器
		if (flag)
		{
			c *= -1;						// 负数变号
		}
		for (int i = 0;;)						// 将结果从低位到高位取出
		{
			s.push_front(c % 10 + '0');
			c /= 10;
			i++;
			if (c == 0) break;
			if (i % 3 == 0)	
			{
				s.push_front(',');				// 每3位添加一个','分隔号
			}
		}
		if (flag)
		{
			s.push_front('-');					// 负数添加'-'负号
		}
		for (;!s.empty();)						// 按顺序输出
		{
			cout << s.front();
			s.pop_front();
		}
		cout << endl;
	}
	//
	// system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值