【PAT (Advanced Level)】1031. Hello World for U (20)

1031. Hello World for U (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n 1characters, then left to right along the bottom line with n 2 characters, and finally bottom-up along the vertical line with n 3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n 1 = n 3 = max { k| k <= n 2 for all 3 <= n 2 <= N } with n 1 + n 2 + n 3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor


这个题目就是要把一个字符串按照“U”型放入一个数组,然后输出这个数组就可以了,主要要注意的就是数组中“U”型拐角的计算

代码如下:

/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
	/*ifstream cin;
	cin.open("in.txt");
	ofstream cout;
	cout.open("out.txt");*/
	//
	// TO DO Whatever You WANT!
	string s;
	while (cin >> s)
	{
		int n1, n2, n3;
		n1 = n3 = (s.length() + 2) / 3;
		n2 = s.length() + 2 - n1 - n3; // 定义n1, n2, n3大小
		char **p = new char*[n1];
		for (int i = 0; i < n1; p[i++] = new char[n2]); // 构造二维数组
		for (int i = 0; i < n1; i++)
		{
			for (int j = 0; j < n2; p[i][j++] = 32); // 初始化二维数组ASCII32是空格
		}

		for (int i = 0; i < n1; i++) // 填入n1
		{
			p[i][0] = s[i];
		}
		for (int i = 1; i < n2; i++) // 填入n2
		{
			p[n1 - 1][i] = s[n1 + i - 1];
		}
		for (int i = 1; i < n3; i++) // 填入n3
		{
			p[n3 - i - 1][n2 - 1] = s[n1 + n2 + i - 2];
		}

		for (int i = 0; i < n1; i++) // 输出数组
		{
			for (int j = 0; j < n2; j++)
			{
				cout << p[i][j];
			}
			cout << endl;
		}
	}
	//
	// system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值