【PAT (Advanced Level)】1050. String Subtraction (20)

1050. String Subtraction (20)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.
这题就是让把在S2中出现的字符从S1中去掉然后输出,很简单,判断一下S1中有没有S2中的字符就可以了;

要注意的是,S1中每个字符依次与S2中每个比较是很不现实的,如果S2有10 ^ 4个,那每个字符比较的时间就很糟糕;

这里我把S2中出现的字符存到了一个bool数组中,这样S2即时有10 ^ 4个字符,那最多也就只有256个ASCII个数字,更何况数组是随机访问不用遍历,大大缩短了时间;

第二点注意的就是不能用cin了,因为字符串中包含空格,我用的是getline();

总体来说很简单;

代码:

/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
	//ifstream cin;
	//cin.open("in.txt");
	//ofstream cout;
	//cout.open("out.txt");
	//
	// TO DO Whatever You WANT!
	string s1, s2;
	while (getline(cin, s1), getline(cin, s2))
	{
		bool flag[256] = { false };
		for (int i = 0; i < s2.length(); i++)
		{
			flag[s2[i]] = true; // S2中出现的字符标记上
		}
		for (int i = 0; i < s1.length(); i++)
		{
			if (flag[s1[i]]) continue; // 如果在S2中,跳过不输出
			cout << s1[i];
		}
		cout << endl;
	}
	//
	// system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值