A - Power Strings (kmp)

点击打开链接

得到next的两种形式

由-1开始

void getnext(char *t, int m) {
    int i = 0, j = 0;
    next[0] = -1; j = next[i];
    while(i < m) {
        if(j == -1 || t[i] == t[j]) {
            next[++i] = ++j;
        }
        else {
            j = next[j];
        }
    }
}
由0开始

void getnext1(char *a,int n)
{
	int i=1,j=0;
	next1[0]=0;j=next1[i-1];
	while(i<n)
	{
		while(j>0&&a[i]!=a[j])
		j=next1[j-1];
		if(a[i]==a[j])
		++j;
		next1[i]=j;
		i++;
	}
}

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题解:

用KMP算法求出next数组后,找到最后一个0的位置,这个就是最短的数结束循环的位置。然后输出 l / (endd + 1) 然后就光荣的wa了。

原因是没有考虑特殊情况,例子:ABABA,输出应该是1,但是按上面的会输出2。所以我们还要判断一下 l 是否能整除 (endd + 1) ,如果不能就输出1。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[1000005];
int next1[1000005];
void getnext1(char *a,int n)
{
	int i=1,j=0;
	next1[0]=0;j=next1[i-1];
	while(i<n)
	{
		while(j>0&&a[i]!=a[j])
		j=next1[j-1];
		if(a[i]==a[j])
		++j;
		next1[i]=j;
		i++;
	}
}
int main()
{
	while(1)
	{
	    scanf("%s",a);
		if(a[0]=='.')
		break;
		int l1=strlen(a);
		int ans=0;
		getnext1(a,l1);
//		for(int i=0;i<l1;i++)
//		printf("%d ",next1[i]);
//		printf("\n");
		for(int i=l1-1;i>=0;i--)
		{
            if(next1[i]==0)
            {
            	if(l1%(i+1)==0)
            	{
            		ans=l1/(i+1);break;	
				}
				else
				{
					ans=1;break;
				}
			}
			
		}
		printf("%d\n",ans);
	}
return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值