B - Factors of Factorial AtCoder - 2286

点击打开链接

Problem Statement

You are given an integer N. Find the number of the positive divisors of N!, modulo 109+7.

Constraints

  • 1N103
Input

The input is given from Standard Input in the following format:

N
Output

Print the number of the positive divisors of N!, modulo 109+7.

Sample Input 1

3
Sample Output 1

4

There are four divisors of 3! =6123 and 6. Thus, the output should be 4.

Sample Input 2

6
Sample Output 2

30
Sample Input 3

1000
Sample Output 3

972926972


#include<cstdio>
#include<cstring>
using namespace std;
static const long long int INF=1e9+7;
int main()
{
	int n;
	int a[10004];
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		
		for(int i=2;i<=n;i++)
		{
		    int m=i;
			for(int j=2;j<=m;j++)
			{
				while(m%j==0)
				{
					a[j]++;
					m/=j;
				}
			}
			if(m!=1)
			a[m]++;
			
		}
		long long int ans=1;
		for(int i=1;i<=n;i++)
		{
			if(a[i]!=0)
			ans=(ans*(a[i]+1))%INF;
		}
		printf("%lld\n",ans);
	}
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值