hdu5428(BestCoder Round #54 (div.2)1002题)

The Factor

Accepts: 101
Submissions: 811
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description
There is a sequence of n positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead.
Input
The first line contains one integer T(1T15) , which represents the number of testcases. For each testcase, there are two lines: 1. The first line contains one integer denoting the value of n(1n100) . 2. The second line contains n integers a1,,an(1a1,,an2×109) , which denote these n positive integers.
Output
Print T answers in T lines.
Sample Input
2
3
1 2 3
5
6 6 6 6 6
Sample Output
6
4
分析:对于每一个数字,它有用的部分其实只有它的所有质因子(包括相等的)。求出所有数的所有质因子中最小的两个,相乘就是答案。如果所有数字的质因子个数不到两个,那么就是无解。
 
   
#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

int a[110],s[100005],vis[100005];
int num;
__int64 sum[300];

void prime()
{
    int i,j;
    CL(vis);
    for (i=4;i<=100000;i+=2)
        vis[i]=-1;
    for (i=3; i<=1000; i++)
    {
        if (i%2==1)
        {
            for (j=i*i;j<=100000;j+=i)
                vis[j]=-1;
        }
    }
    for (i=2; i<=100000; i++)
        if (vis[i]==0)
        s[num++]=i;
    return ;
}

int main ()
{
    int T,n;
    scanf ("%d",&T);
    num=0;
    prime();
    while (T--)
    {
        scanf ("%d",&n);
        int tt=0;
        for (int i=0; i<n; i++)
        {
            scanf ("%d",&a[i]);
            int flag=0;
            for(int j=0;j<num;j++)
            {
                if(!flag&&a[i]%s[j]==0)
                {
                    if(a[i]%(s[j]*s[j])==0)
                    {
                        sum[tt++]=s[j];
                        sum[tt++]=s[j];
                        flag=2;
                        break;
                    }
                    else
                    {
                        flag=1;
                        sum[tt++]=s[j];
                    }
                }
                else if(a[i]%s[j]==0)
                {
                    sum[tt++]=s[j];
                    flag=2;
                    break;
                }
            }
            //cout<<1<<endl;
            if(!flag&&a[i]!=1)
                sum[tt++]=a[i];
        }
        sort(sum,sum+tt);
        if (tt<=1) printf ("-1\n");
        else printf ("%I64d\n",sum[0]*sum[1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值